forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-eselect/eselect-repository: Bump to v2
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST eselect-repository-1.tar.gz 5378 SHA256 d73d4ab5fd525f3504814b25087a051bde1b358033f996e10eca3d5eeeeabf22 SHA512 7f985c3abe3fa02dfe44aade71583e7280c4757470fe8bf43de8fcc2403e8b924d9b0af104e926a2b3cd79a92b440570347db511767c908dda087ccc9f3aba6e WHIRLPOOL 8ad0d21452a0094007b795aa105312110404dca33ee8c8e3c189b08f9fbad7759c2f1fe6572839c06cb7bdbaa39740195d674e72dc72debf6f118570d40daec2 | ||
DIST eselect-repository-2.tar.gz 5441 BLAKE2B 28608b7e5d06747afea4ef28b0f45ac97dcea0310201d857f1248e7fc586a331fce01c9017df83c332cbfb55b51b52a45361e06db8a7d4b788a70f63eb4c83d8 SHA512 7667053b7d06117f49366d7bb6ad39b1b0715c778e49e18649ce38b364e58c0c31f4fa077a459374c52d3bb7f550002a4368cbb7fc14fd9961815bb1355c1f61 |
39 changes: 39 additions & 0 deletions
39
app-eselect/eselect-repository/eselect-repository-2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python{3_4,3_5,3_6} ) | ||
inherit python-single-r1 | ||
|
||
DESCRIPTION="Manage repos.conf via eselect" | ||
HOMEPAGE="https://github.com/mgorny/eselect-repository" | ||
SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="${PYTHON_DEPS} | ||
app-admin/eselect | ||
dev-python/lxml[${PYTHON_USEDEP}] | ||
net-misc/wget" | ||
|
||
src_compile() { | ||
MAKEARGS=( | ||
PREFIX="${EPREFIX}/usr" | ||
SYSCONFDIR="${EPREFIX}/etc" | ||
SHAREDSTATEDIR="${EPREFIX}/var" | ||
ESELECTDIR="${EPREFIX}/usr/share/eselect/modules" | ||
) | ||
|
||
emake "${MAKEARGS[@]}" | ||
python_fix_shebang eselect-repo-helper | ||
} | ||
|
||
src_install() { | ||
emake "${MAKEARGS[@]}" DESTDIR="${D}" install | ||
keepdir /var/db/repos | ||
einstalldocs | ||
} |