Skip to content

Commit

Permalink
media-sound/flac-image: [QA] Various fixes
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
SoapGentoo committed Jun 3, 2017
1 parent aea24fb commit 0a8189a
Show file tree
Hide file tree
Showing 3 changed files with 42 additions and 19 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- a/flac-image.c
+++ b/flac-image.c
@@ -15,6 +15,7 @@
*/

#include <stdio.h>
+#include <string.h>
#include <unistd.h>
#include <sys/stat.h>
#include <fcntl.h>
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
Fix Makefile to respect user variables

--- a/Makefile
+++ b/Makefile
@@ -3,9 +3,8 @@
# by default, you probably need to add -I/usr/whereever/flac to CFLAGS and
# -L/usr/lib/whereever to the link step.

-CFLAGS="-Wall -g"
-
flac-image: flac-image.o
- gcc -o flac-image -lFLAC flac-image.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lFLAC

-flac-image: flac-image.c flac-image.h
\ No newline at end of file
+flac-image.o: flac-image.c flac-image.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
33 changes: 14 additions & 19 deletions media-sound/flac-image/flac-image-1.00.ebuild
Original file line number Diff line number Diff line change
@@ -1,40 +1,35 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=4
EAPI=6

inherit eutils
inherit toolchain-funcs

DESCRIPTION="Utility for stuffing image files (e.g. album cover art) into metadata blocks in FLAC files"
DESCRIPTION="Utility for adding image files (e.g. album cover art) to metadata of FLAC files"
HOMEPAGE="http://www.singingtree.com/software/"
SRC_URI="http://www.singingtree.com/software/${PN}.tar.gz -> ${P}.tar.gz"
# FIXME: no version in tarball, but also no updates for a long time. So it's ok.
LICENSE="BSD"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="media-libs/flac"
RDEPEND="${DEPEND}"

S="${WORKDIR}"
S=${WORKDIR}

# compile helper
_compile() {
local CC="$(tc-getCC)"
echo "${CC} ${@}" && "${CC}" "${@}"
}
PATCHES=(
"${FILESDIR}"/${PN}-1.00-add-missing-string-include.patch
"${FILESDIR}"/${PN}-1.00-fix-build-system.patch
)

src_prepare() {
sed -i -e "s:^\(#include <stdio.h>\):\1\n#include <string.h>:g" "${PN}.c"
rm -f -- "${PN}" # remove pre-compiled binary
}
src_configure() {
# remove pre-compiled binary
rm -f "${PN}" || die

src_compile() {
# Makefile is both simple and broken, so we compile the binary ourself.
_compile ${CFLAGS} ${LDFLAGS} -o "${PN}" "${PN}.c" -lFLAC \
|| die "compile failed"
tc-export CC
}

src_install() {
Expand Down

0 comments on commit 0a8189a

Please sign in to comment.