Skip to content

Commit

Permalink
dev-python/importlib_metadata: bump to 0.19
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Louis Sautier <[email protected]>
  • Loading branch information
sbraz committed Jul 29, 2019
1 parent f4d9be6 commit 0a847c4
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/importlib_metadata/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST importlib_metadata-0.18.tar.gz 23341 BLAKE2B e1c43a760b141b0589973672ad1cd6c47e077293353f67ebe2c2b3631265712dcecc8e14a57803539d2276d5d908fae3c4ac07165ddd5937cf53955ff896001e SHA512 2f39789725548bcb37061b0b99f90802a2919339db6b29f95b38811b35f4cafc7acfb4cca1167e28a4738ba195af31344f59ab457d87710764d1ba8f06034b18
DIST importlib_metadata-0.19.tar.gz 23338 BLAKE2B 10c43bee5324804b359f951e5d375559e3a58663b11f0bda1b39ce82dcdd0ba735083793a954e2ac18b5fd607d9ea5628a86f9c345c83d718a7e46738774e0ee SHA512 2d0126e7430804b2295ec159778082806957cb86b5c7408c38064cc7c7e62229d382778284a5a231925ab336a7cc6da8e705f6bd7ae6da66f11acd1229bda17b
51 changes: 51 additions & 0 deletions dev-python/importlib_metadata/importlib_metadata-0.19.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )

inherit distutils-r1

DESCRIPTION="Read metadata from Python packages"
HOMEPAGE="https://importlib-metadata.readthedocs.io/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="doc test"

RDEPEND="
dev-python/zipp[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/configparser-3.5[${PYTHON_USEDEP}]' -2)
$(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' -2)
$(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
${RDEPEND}
$(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' pypy pypy3 python2_7 python3_5 python3_6)
)
doc? (
>=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
)
"
python_prepare_all() {
sed -i "/'sphinx.ext.intersphinx'/d" ${PN}/docs/conf.py || die
distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc; then
sphinx-build ${PN}/docs docs/_build/html || die
HTML_DOCS=( docs/_build/html/. )
fi
}

python_test() {
"${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
}

0 comments on commit 0a847c4

Please sign in to comment.