Skip to content

Commit

Permalink
app-shells/fish: add nls support
Browse files Browse the repository at this point in the history
This adds nls useflag and includes
backported upstream patch to honor LINGUAS.
Fixes bug 409969.
Closes: gentoo#4072
  • Loading branch information
gyakovlev authored and Lars Wendler committed Mar 3, 2017
1 parent e2fd0ed commit 0ab0ecc
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 3 deletions.
32 changes: 32 additions & 0 deletions app-shells/fish/files/fish-2.5.0-honor-linguas.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
diff --git a/Makefile.in b/Makefile.in
index 35e63ae..b73c612 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -195,11 +195,16 @@ ifeq ($(shell uname), Darwin)
endif

#
-# All translation message catalogs
+# All translation message catalogs, filter files based on LINGUAS.
#
TRANSLATIONS_SRC := $(wildcard po/*.po)
-ifdef HAVE_GETTEXT
+ifeq ($(HAVE_GETTEXT), 1)
TRANSLATIONS := $(TRANSLATIONS_SRC:.po=.gmo)
+ifdef LINGUAS
+ TRANSLATIONS_ALL := $(TRANSLATIONS)
+ TRANSLATIONS_WANTED = $(patsubst %,po/%.gmo,$(LINGUAS))
+ TRANSLATIONS = $(filter $(TRANSLATIONS_WANTED),$(TRANSLATIONS_ALL))
+endif
else
TRANSLATIONS :=
endif
@@ -764,7 +769,7 @@ uninstall: uninstall-translations | show-prefix show-bindir show-sysconfdir show
.PHONY: uninstall

install-translations: $(TRANSLATIONS) | show-HAVE_GETTEXT
-ifdef HAVE_GETTEXT
+ifeq ($(HAVE_GETTEXT), 1)
@echo "Installing translations..."
$v for i in $(TRANSLATIONS); do \
$(INSTALL) -m 755 -d $(DESTDIR)$(localedir)/`basename $$i .gmo`/LC_MESSAGES; \
9 changes: 6 additions & 3 deletions app-shells/fish/fish-2.5.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE=""
IUSE="nls"

RDEPEND="
>=dev-libs/libpcre2-10.21[pcre32]
Expand All @@ -19,17 +19,20 @@ RDEPEND="
DEPEND="
${RDEPEND}
sys-devel/bc
sys-devel/gettext
nls? ( sys-devel/gettext )
"

PATCHES=( "${FILESDIR}/${P}-honor-linguas.patch" )

src_configure() {
# Set things up for fish to be a default shell.
# It has to be in /bin in case /usr is unavailable.
# Also, all of its utilities have to be in /bin.
econf \
docdir="${EPREFIX}"/usr/share/doc/${PF} \
--bindir="${EPREFIX}"/bin \
--without-included-pcre2
--without-included-pcre2 \
$(use_with nls gettext)
}

src_test() {
Expand Down

0 comments on commit 0ab0ecc

Please sign in to comment.