forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/aiohttp-cors: Bump to v0.5.3
Required for net-misc/gns3-server. Package-Manager: Portage-2.3.24, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
42 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST aiohttp-cors-0.5.0.tar.gz 40018 BLAKE2B 774b3da8f459828145253f21dfcd10741b428e5594b2e02c42d3b46fdc8bb3821ec53f93547665d4b56758684358f3626d811f4dbe6490a01b40b4f274ba3a0c SHA512 86c24a1fe18fb3b2b8fca38ef9aa7ebf07fc1b202d353a540b7d651cbf618c57c5afbe125d91c0d72aee937909dbea0cfb1baa182eebdc5402b66f9800706bee | ||
DIST aiohttp-cors-0.5.1.tar.gz 40081 BLAKE2B f491bcebf406b089baeccb62c1ce113fc3ef485f3103a24ef93b08b1b33b66c2f419f58dac80f8d6c262e4826762a27dbde479c8de6c17fe991a3b084f0dc061 SHA512 a06f65a479bbed50022394d51345e08bdf98a099f4b6efe355f4a4762155a564eee3d4e10ddb417daa7498ebc1abb93a3437b1a2cc6af9c2ad5fe8a8714c237c | ||
DIST aiohttp-cors-0.5.3.tar.gz 40266 BLAKE2B 701886b291a1b89f88a704ae04e3264cf2afc51f63f03ddd4464d40ba7bd3a1c6b5fe3f095b634e8c6c36c5a967e9a6b9b88335ff23988fc8bcd726c037fbd1c SHA512 0813ea48de714c85e361dfdaeef1a69526f7446dcc4ce637139cd333dedea58c635f85cfad1c3ccfb0df6e573f0351f282fdbd9726211d5915ed2ba120206b09 | ||
DIST aiohttp-cors-0.6.0.tar.gz 42507 BLAKE2B 7b63916b983d3dc208058c8b04445a30762eebc4999135ae802d1ceeeccc476a335eae66126bb3fd16f938af3649e8b9096433c2df09e82bf4e5d4ba8e38c42c SHA512 75453ebbc074d5f25cc8efc46ffdb76fc90b0a96a9e6fce0eee5a5f28dba31cb50301289cac3b36c70ccdbc10c8f4ba9e362d8e9f350ba7f9dfacd06e6f5e699 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python3_4 python3_5 python3_6 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server" | ||
HOMEPAGE="https://github.com/aio-libs/aiohttp-cors" | ||
SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}] | ||
$(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python3_4)" | ||
DEPEND="${RDEPEND} | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
dev-python/pytest-cov[${PYTHON_USEDEP}] | ||
dev-python/pytest-pylint[${PYTHON_USEDEP}] | ||
dev-python/pytest-runner[${PYTHON_USEDEP}] | ||
dev-python/selenium[${PYTHON_USEDEP}] | ||
)" | ||
|
||
python_prepare_all() { | ||
# for some reason, it is installed by 'setup.py test' on py!=3.4 | ||
# TODO: investigate | ||
sed -i -e '/typing/d' setup.py || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
esetup.py test | ||
} |