Skip to content

Commit

Permalink
dev-cpp/pangomm: Version bump to 2.48.1
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed May 22, 2021
1 parent e7f772f commit 0ac6a5c
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/pangomm/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pangomm-2.42.2.tar.xz 656760 BLAKE2B 8fae779aa78b2337b83759adc7aadec1f61c08c54d892e3cdd05180e2ab032a61faa72c39281fab649bcd08591c5d7ace9ea65b25f76ce17d6f4d96f38900b6a SHA512 5e4826d64c0178527b4df73e901d2fdf5661d41777e189f5e2d4b26577e42689efaccf5a28502246c6b3926571ccd5876cb23d33267b44ace7ee164322c14667
DIST pangomm-2.48.0.tar.xz 674516 BLAKE2B 58c3e93c6127a14b5bc866b43bff4ab25a1ac1a06813c73e4f2a4d02adad3f51b7ec922f7c6e3d4af518a1f8f31c19de4df0c11b91a10ee61c2e16df8aa025ea SHA512 0c1be5726740669c366214caf8b8b0bca1c7b223aafb2e6ce64f7a5a90d07c62ee509821ac787f3997ae78aa3a3ffd5cff7d33c73bc7ebd7fe642c56689d98a3
DIST pangomm-2.48.1.tar.xz 675452 BLAKE2B bb012fc5cb66d5cb98f522e3706fdd35bcc5692fcd942f86ee1e20116590ceca26874c5a58bd3f8fac4f154700dfb37ea060747a6c3069e67adf83ba551e7abc SHA512 c204a1cb7a404f055d62880a760716c5567a835ca495cc5e01589ed59fabb332490e529de716c3438cefbc4428c025d6d01c71e4412b2843e3ab3a3175ccc2f4
51 changes: 51 additions & 0 deletions dev-cpp/pangomm/pangomm-2.48.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )
inherit gnome.org meson multilib-minimal python-any-r1

DESCRIPTION="C++ interface for pango"
HOMEPAGE="https://www.gtkmm.org"

LICENSE="LGPL-2.1+"
SLOT="2.48"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
IUSE="doc"

DEPEND="
>=dev-cpp/cairomm-1.16.0:1.16[doc?,${MULTILIB_USEDEP}]
>=dev-cpp/glibmm-2.68.0:2.68[doc?,${MULTILIB_USEDEP}]
>=dev-libs/libsigc++-3:3[doc?,${MULTILIB_USEDEP}]
>=x11-libs/pango-1.48.0[${MULTILIB_USEDEP}]
"
RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
doc? (
app-doc/doxygen[dot]
dev-lang/perl
dev-libs/libxslt
)
${PYTHON_DEPS}
"

multilib_src_configure() {
local emesonargs=(
-Dbuild-documentation=$(multilib_native_usex doc true false)
)
meson_src_configure
}

multilib_src_compile() {
meson_src_compile
}

multilib_src_install() {
meson_src_install
}

multilib_src_test() {
meson_src_test
}

0 comments on commit 0ac6a5c

Please sign in to comment.