forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Fix build with >=texinfo-5.2 and LINGUAS="ja" Package-Manager: portage-2.3.0_rc1 Signed-off-by: Andrew Savchenko <[email protected]>
- Loading branch information
Showing
2 changed files
with
284 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,137 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit autotools elisp-common flag-o-matic | ||
|
||
DESCRIPTION="Any to PostScript filter" | ||
HOMEPAGE="http://www.inf.enst.fr/~demaille/a2ps/" | ||
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz | ||
linguas_ja? ( mirror://gentoo/${P}-ja_nls.patch.gz )" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos" | ||
IUSE="emacs latex linguas_ja nls static-libs userland_BSD userland_GNU vanilla" | ||
|
||
RESTRICT=test | ||
|
||
RDEPEND="app-text/ghostscript-gpl | ||
app-text/libpaper | ||
>=app-text/psutils-1.17 | ||
app-text/wdiff | ||
emacs? ( virtual/emacs ) | ||
latex? ( virtual/latex-base ) | ||
nls? ( virtual/libintl ) | ||
userland_GNU? ( >=sys-apps/coreutils-6.10-r1 ) | ||
userland_BSD? ( sys-freebsd/freebsd-ubin )" | ||
DEPEND="${RDEPEND} | ||
>=dev-util/gperf-2.7.2 | ||
virtual/yacc | ||
nls? ( sys-devel/gettext )" | ||
|
||
SITEFILE=50${PN}-gentoo.el | ||
|
||
S=${WORKDIR}/${PN}-${PV:0:4} | ||
|
||
src_prepare() { | ||
default | ||
|
||
eapply "${FILESDIR}"/${PN}-4.13c-locale-gentoo.diff | ||
use vanilla || eapply -p0 "${FILESDIR}"/${PN}-4.13-stdout.diff | ||
if use linguas_ja; then | ||
eapply "${WORKDIR}"/${P}-ja_nls.patch | ||
# bug #335803 | ||
eapply -p0 "${FILESDIR}"/${P}-ja-cleanup.patch | ||
else | ||
eapply "${FILESDIR}"/${P}-cleanup.patch | ||
fi | ||
|
||
# fix fnmatch replacement, bug #134546 | ||
eapply "${FILESDIR}"/${PN}-4.13c-fnmatch-replacement.patch | ||
|
||
# bug #122026 | ||
eapply "${FILESDIR}"/${P}-psset.patch | ||
|
||
# fix emacs printing, bug #114627 | ||
eapply "${FILESDIR}"/a2ps-4.13c-emacs.patch | ||
|
||
# fix chmod error, #167670 | ||
eapply "${FILESDIR}"/a2ps-4.13-manpage-chmod.patch | ||
|
||
# add configure check for mempcpy, bug 216588 | ||
eapply "${FILESDIR}"/${P}-check-mempcpy.patch | ||
|
||
# fix compilation error due to invalid stpcpy() prototype, bug 216588 | ||
eapply -p0 "${FILESDIR}"/${P}-fix-stpcpy-proto.patch | ||
|
||
# fix compilation error due to obstack.h issue, bug 269638 | ||
eapply "${FILESDIR}"/${P}-ptrdiff_t.patch | ||
|
||
# fix compilation error due to texinfo 5.x, bug 482748 | ||
eapply "${FILESDIR}"/${P}-texinfo-5.x.patch | ||
|
||
# fix building with sys-devel/automake >= 1.12, bug 420503 | ||
rm -f {.,ogonkify}/aclocal.m4 || die | ||
sed -i \ | ||
-e '/^AM_C_PROTOTYPES/d' \ | ||
-e '/^AUTOMAKE_OPTIONS.*ansi2knr/d' \ | ||
-e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \ | ||
-e 's:AM_PROG_CC_STDC:AC_PROG_CC:' \ | ||
configure.in {contrib/sample,lib,src}/Makefile.am m4/protos.m4 || die | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
append-cppflags -DPROTOTYPES #420503 | ||
|
||
local myconf="COM_netscape=no COM_acroread=no" | ||
|
||
use emacs || myconf="${myconf} EMACS=no" | ||
use latex || myconf="${myconf} COM_latex=no" | ||
|
||
export LANG=C LC_ALL=C | ||
|
||
econf \ | ||
--enable-shared \ | ||
$(use_enable static-libs static) \ | ||
--sysconfdir="${EPREFIX}"/etc/a2ps \ | ||
$(use_enable nls) \ | ||
${myconf} | ||
} | ||
|
||
src_compile() { | ||
# parallel make b0rked | ||
emake -j1 | ||
} | ||
|
||
src_install() { | ||
emake \ | ||
DESTDIR="${D}" \ | ||
lispdir="${EPREFIX}${SITELISP}"/${PN} \ | ||
install | ||
|
||
newdoc "${ED}"/usr/share/a2ps/README README.a2ps | ||
newdoc "${ED}"/usr/share/a2ps/ppd/README README.a2ps.ppd | ||
newdoc "${ED}"/usr/share/ogonkify/README README.ogonkify | ||
|
||
rm -f "${ED}"/usr/share/{a2ps,a2ps/ppd,ogonkify}/README || die | ||
|
||
prune_libtool_files | ||
|
||
if use emacs; then | ||
elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die | ||
fi | ||
|
||
dodoc ANNOUNCE AUTHORS ChangeLog FAQ NEWS README* THANKS TODO | ||
} | ||
|
||
pkg_postinst() { | ||
use emacs && elisp-site-regen | ||
} | ||
|
||
pkg_postrm() { | ||
use emacs && elisp-site-regen | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,147 @@ | ||
--- a2ps-4.14/doc/a2ps.texi.bero 2013-03-26 10:31:31.230137555 +0100 | ||
+++ a2ps-4.14/doc/a2ps.texi 2013-03-26 11:01:01.504006086 +0100 | ||
@@ -44,10 +44,6 @@ | ||
@end ifnottex | ||
|
||
@c TeX variants | ||
-@macro LaTeX | ||
-La@TeX{} | ||
-@end macro | ||
- | ||
@macro PreTeX | ||
Pre@TeX{} | ||
@end macro | ||
@@ -417,9 +413,9 @@ Genesis | ||
@c Now, that's what I call humor :) | ||
@cindex First Page | ||
This document describes GNU @pack{} version @value{VERSION}. The latest | ||
-versions may be found on the @href{@value{WWWHOME},@pack{} home page}. | ||
-We plan to update the @href{http://www.gnu.org/software/a2ps/, GNU | ||
-@pack{} home page} in the near future, in which case the latter will be | ||
+versions may be found on the @uref{@value{WWWHOME}, home page}. | ||
+We plan to update the @uref{@value{WWWHOME}, GNU home page} | ||
+in the near future, in which case the latter will be | ||
a better source of information. | ||
|
||
We tried to make this document informative and pleasant. It tries to be | ||
@@ -431,8 +427,8 @@ difficult to use. @xref{Glossary}, for | ||
information. | ||
|
||
Please, send us emailcards @code{:)}. Whatever the comment is, or if you | ||
-just like @pack{}, write to @email{Miguel.Santana@@st.com, Miguel | ||
-Santana} and @email{akim@@freefriends.org, Akim Demaille}. But | ||
+just like @pack{}, write to @email{Miguel.Santana@@st.com, Miguel Santana} | ||
+and @email{akim@@freefriends.org, Akim Demaille}. But | ||
@emph{never} write to either of us for asking questions, or to report | ||
bugs. Chances are very high never to receive an answer, as we receive | ||
too many messages. @xref{a2ps Mailing Lists}, for information on the | ||
@@ -517,8 +513,8 @@ everybody so that mistakes get fixed as | ||
|
||
So, if you have a problem (configuration error, compilation error, | ||
runtime error, documentation error or unclear), first check in the FAQ | ||
-(@pxref{FAQ}), then on the page @href{@value{WWWHOME}/bugs.html,Known | ||
-@pack{} Bugs} if the issue has not been addressed yet. If it is not the | ||
+(@pxref{FAQ}), then on the page @uref{@value{WWWHOME}/bugs.html,Known Bugs} | ||
+if the issue has not been addressed yet. If it is not the | ||
case, but it appears that the version of @pack{} you have is old, | ||
consider upgrading. | ||
|
||
@@ -2802,8 +2798,7 @@ Thou shalt start your PostScript DSC con | ||
|
||
The bad news is that some printers will reject this header. Then you | ||
may change this header without any worry since the PostScript produced | ||
-by @pack{} is also 100% PostScript level 1@footnote{That is to say, there | ||
-are no PostScript printers that don't understand these files.}. | ||
+by @pack{} is also 100% PostScript level 1@footnote{That is to say, there are no PostScript printers that don't understand these files.}. | ||
|
||
@defvr {Configuration Setting} OutputFirstLine: @var{magic-number} | ||
@cindex @samp{OutputFirstLine:} | ||
@@ -3971,13 +3966,13 @@ Quote @var{text} so that no special sequ | ||
@itemx \end@{enumerate@} | ||
@itemx \begin@{description@} | ||
@itemx \end@{description@} | ||
-These commands are legal in @LaTeX but have no sense in @PreTeX{}. | ||
+These commands are legal in @LaTeX{} but have no sense in @PreTeX{}. | ||
Hence there are simply ignored and not printed (if immediately followed | ||
by an end-of-line). | ||
@end table | ||
|
||
@node Differences with LaTeX | ||
-@subsubsection Differences with @LaTeX | ||
+@subsubsection Differences with @LaTeX{} | ||
The following symbols, inherited from the style sheet @code{Symbol}, are | ||
not supported by @LaTeX{}: | ||
|
||
@@ -4124,9 +4119,9 @@ beautiful, with any character you might | ||
prefix part of the file name, and is alpha-numerical, lower case, and | ||
less than 8 characters long. | ||
|
||
-Anywhere @pack{} needs to recognize a style sheet by a name, @strong{it | ||
-uses the key} (in the @file{sheets.map} file, with the option @samp{-E}, | ||
-etc.). | ||
+Anywhere @pack{} needs to recognize a style sheet by a name, | ||
+@strong{it uses the key} (in the @file{sheets.map} file, with the | ||
+option @samp{-E}, etc.). | ||
|
||
As an example, C++ is implemented in a file called @file{cxx.ssh}, in | ||
which the name is declared to be @samp{C++}. | ||
@@ -5672,7 +5667,7 @@ supporting a @samp{--help}-like option. | ||
@subsection Invoking @code{card} | ||
|
||
@example | ||
-card [@var{options}] @var{applications} [-- @var{@pack{}-options}] | ||
+card [@var{options}] @var{applications} [-- @var{-options}] | ||
@end example | ||
|
||
@noindent | ||
@@ -5680,7 +5675,7 @@ card [@var{options}] @var{applications} | ||
@var{applications}' help message (typically by the options @samp{--help} | ||
or @samp{-h}), and pretty prints it thanks to @pack{} (or the content of | ||
the environment variable @samp{A2PS} if it is set). | ||
-@var{@pack{}-options} are passed to @pack{}. | ||
+@var{-options} are passed to @pack{}. | ||
|
||
Supported options are: | ||
|
||
@@ -5874,12 +5869,12 @@ difference finder,wdiff,GNU wdiff}) to e | ||
@subsection Invoking @code{pdiff} | ||
|
||
@example | ||
-pdiff [@var{options}] @var{file-1} @var{file-2} [-- @var{@pack{}-options}] | ||
+pdiff [@var{options}] @var{file-1} @var{file-2} [-- @var{-options}] | ||
@end example | ||
|
||
@noindent | ||
make a pretty comparison between @var{file-1} and @var{file-2}. | ||
-@var{@pack{}-options} are passed to @pack{}. | ||
+@var{-options} are passed to @pack{}. | ||
|
||
Supported options are: | ||
|
||
@@ -6222,7 +6217,7 @@ Error related questions. | ||
@subsection Why Does it Print Nothing? | ||
|
||
@quotation | ||
-@i{@pack{} works OK, but the printer prints nothing.} | ||
+@i{works OK, but the printer prints nothing.} | ||
@end quotation | ||
|
||
There are two ways that printing can fail: silently, or with a | ||
@@ -6351,7 +6346,7 @@ If it is incorrect, ask for help around | ||
@subsection Why Does it Say my File is Binary? | ||
|
||
@quotation | ||
-@i{@pack{} complains that my file is binary though it is not.} | ||
+@i{complains that my file is binary though it is not.} | ||
@end quotation | ||
|
||
There are several reasons that can cause @pack{} to consider a file is | ||
@@ -6591,7 +6586,7 @@ format you want for the date: @xref{Esca | ||
@subsection Why Have the Options Changed? | ||
|
||
@quotation | ||
-@i{The options of this @pack{} are not the same as in the previous versions.} | ||
+@i{The options of this are not the same as in the previous versions.} | ||
@end quotation | ||
|
||
True. But the old scheme (up to version 4.6.1) prevented us from |