Skip to content

Commit

Permalink
dev-python/flake8: Bump to 7.1.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 5, 2024
1 parent a10f241 commit 0ad6509
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/flake8/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST flake8-7.1.0.gh.tar.gz 138600 BLAKE2B df6781e676d4eccf296d5fc3d767643956799d1c99adccb32d0005951f0aca13b7e99ff7506f7026e9ed6c2dd78d5bdd02d9a25aaf64a1353097b8a9c02c5739 SHA512 0e970bdb0facff3a6e2ee33a74fe77ee1f7c80fbc517125df34d831ff897e222d0955d56fa9e9eedef83ccdc4e92aa7bbc583517d7b19a8cf1041790a225693a
DIST flake8-7.1.1.gh.tar.gz 138915 BLAKE2B 5c00c4a95f0757f7d3716270ca1de91580cb1731c700227d563c08798981c124c5789f40a5965ad49450a77601ab9638d04cb32ef9c13418720c4123ba2a7932 SHA512 310457e3c701f746d812cc76664bcb79c7cbc320af9d757ebbc13c847f2c3864770d9b945694b4b6abb773ae636e19175222c3dab74d34559beaa7835f1d9931
60 changes: 60 additions & 0 deletions dev-python/flake8/flake8-7.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..13} )

inherit distutils-r1

DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
HOMEPAGE="
https://github.com/PyCQA/flake8/
https://pypi.org/project/flake8/
"
SRC_URI="
https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"

RDEPEND="
=dev-python/pyflakes-3.2*[${PYTHON_USEDEP}]
=dev-python/pycodestyle-2.12*[${PYTHON_USEDEP}]
"
PDEPEND="
=dev-python/mccabe-0.7*[${PYTHON_USEDEP}]
"
BDEPEND="
${RDEPEND}
test? (
${PDEPEND}
)
"

distutils_enable_sphinx docs/source \
dev-python/sphinx-prompt \
dev-python/sphinx-rtd-theme
distutils_enable_tests pytest

python_test() {
local EPYTEST_DESELECT=(
# fails if additional flake8 plugins are installed
tests/integration/test_plugins.py::test_local_plugin_can_add_option
)
if [[ ${EPYTHON} == pypy3 ]]; then
EPYTEST_DESELECT+=(
# problem with pypy3.10 in dev-python/pyflakes
# https://github.com/PyCQA/pyflakes/issues/779
tests/integration/test_main.py::test_malformed_per_file_ignores_error
tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
)
fi

epytest
}

0 comments on commit 0ad6509

Please sign in to comment.