Skip to content

Commit

Permalink
media-libs/vulkan-loader: Bump to 1.1.92.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Nick Sarnie <[email protected]>
  • Loading branch information
sarnex committed Nov 30, 2018
1 parent e53ac1e commit 0afebfa
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 2 deletions.
1 change: 1 addition & 0 deletions media-libs/vulkan-loader/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST vulkan-loader-1.1.77.0.tar.gz 1512876 BLAKE2B bf5fbf3623f0ca2b2473d496edd23ce388313d7dbeb8e3f95549da5726a1ab25fcce673d5dd3df094d3abdd2c5ecc4a87759a80e7d05d7b34abf30ee325895f2 SHA512 95fe179c93df1ea36cee8123588b232433c988e9a5889a606e7adbc4192d6a4bc8809f9936cf11ae953090392d0c9e4265697b608adacc7eb7cf6479baf49f48
DIST vulkan-loader-1.1.82.0.tar.gz 1342427 BLAKE2B 4b2c589e2c1edaa29e13e892cc839f2d7af5bbadf7dda3f50eca2543c1877af175e9640545b886ffe3e8b1c51373502ee272829ddb15c07629ea08ece697e5b9 SHA512 624e493454e622e29bc0de5fdf1c425691b3c98f317660847e95aee6bc42dafa0b4d8caa9de52e8f3229b7e743afa475485cd3affbdb295e16ba49d30d1eb19e
DIST vulkan-loader-1.1.92.1.tar.gz 1346712 BLAKE2B 60d29c38e72ff234261a3e75934d44de08c334c475e715066c210844ea672f0e2db3ebc8826df7d72392e3c2a0bbd0604b8770c0b35ddd8f72ed875234bae15d SHA512 c29d1fb43a2bdd0f291860dee0ffe7ec23a34c9431aeb76a46f8df0ec2f70601ccd3e96280f94d881f5550e3c9f07fe478f94eebcfd2aaf123045c7281313aac
59 changes: 59 additions & 0 deletions media-libs/vulkan-loader/vulkan-loader-1.1.92.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Loader.git"
EGIT_SUBMODULES=()
inherit git-r3
else
KEYWORDS="~amd64"
EGIT_COMMIT="4cd7e44fc1ca6c4d8361720b43a3588ddf9fc4b6"
SRC_URI="https://github.com/KhronosGroup/Vulkan-Loader/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Vulkan-Loader-${EGIT_COMMIT}"
fi

inherit python-any-r1 cmake-multilib

DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Loader"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="layers wayland X"

PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"
DEPEND="${PYTHON_DEPS}
>=dev-util/vulkan-headers-1.1.92.0
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
)"

multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=True
-DBUILD_TESTS=False
-DBUILD_LOADER=True
-DBUILD_WSI_MIR_SUPPORT=False
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
-DVULKAN_HEADERS_INSTALL_DIR="/usr"
)
cmake-utils_src_configure
}

multilib_src_install() {
keepdir /etc/vulkan/icd.d

cmake-utils_src_install
}

pkg_postinst() {
einfo "USE=demos has been dropped as per upstream packaging"
einfo "vulkaninfo is now available in the dev-util/vulkan-tools package"
}
4 changes: 2 additions & 2 deletions media-libs/vulkan-loader/vulkan-loader-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -26,7 +26,7 @@ IUSE="layers wayland X"

PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"
DEPEND="${PYTHON_DEPS}
>=dev-util/vulkan-headers-1.1.82.0
>=dev-util/vulkan-headers-1.1.92.0
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
Expand Down

0 comments on commit 0afebfa

Please sign in to comment.