Skip to content

Commit

Permalink
dev-libs/libsodium: Version bump to 1.0.7
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
mrueg committed Dec 11, 2015
1 parent 16f1683 commit 0b5a5b4
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libsodium/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libsodium-1.0.2.tar.gz 1673394 SHA256 961d8f10047f545ae658bcc73b8ab0bf2c312ac945968dd579d87c768e5baa19 SHA512 15fc47516f0e35906c1c304205fa991e74a273e4e6fc2186b6c16f0e41523de24493e149262b97ef03e4adc221232372ef1f283c4c23f96e4c5d99023d361e14 WHIRLPOOL 18509d9911c1d0ec6e8b9a8735abfeb2c1623669d31045abc6d9dd1289571fbe3a055f960f42a86779e7c03967532d71d7b9d0597ecfe457672e69b27b577e48
DIST libsodium-1.0.5.tar.gz 1787478 SHA256 bfcafc678c7dac87866c50f9b99aa821750762edcf8e56fc6d13ba0ffbef8bab SHA512 978867f7499ec07817a95213baea79fd45d3cdd48c343723490471f79a1b0df2fa0638a91c46a08717fe03a1d8b68789445cb34be969d91023ba7edc8750835c WHIRLPOOL a46f6ca3eb98151cbc230aa1fd344b4038415f717382fa912f1750c83ed73bcc778fd634cdb7ae9c81b79c94b2d3e949a63d10adaf1ec822ba4be4e4b6fd7620
DIST libsodium-1.0.6.tar.gz 1791565 SHA256 940d03ea7d2caa7940e24564bf6d9f66d6edd1df1e0111ff8e3655f3b864fb59 SHA512 f1232bfd31f8ba60650f594af469e48797924de0d2ce1e9bd0be75614e19b77727b3bcaa9a553cd5613db92738caea79edca5f2ff77ab392b1dff570dcd6be7d WHIRLPOOL e29abdc4ee4687b0bf53f8fcc5f2f276b00d0fd3045faeac5469ba70a54611ea633e3cd9bb9347c467c05c8b0bdd4094683491b31a50d7ab664a8e903e31a529
DIST libsodium-1.0.7.tar.gz 1808032 SHA256 7ad1e78763510c163ca48f05133057726a825cf97386c581bf12b01d7654204a SHA512 21a2991010bc4e6e03d42c6df5443049c99f7622dc68a7bdc3d6d082621a165faab32612280526509d310ad1faefc00aa21c594a384a7fa8b05f4666e82e5e1d WHIRLPOOL a8fe262217365f348c36c6a789fdd7fe479e72c88a8314804b3d7b6154a8cad0ab8517ee9d517fdf407d7d5b6a789868a4a5ac66d9ecf2575917c42bbc3eb49c
35 changes: 35 additions & 0 deletions dev-libs/libsodium/libsodium-1.0.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils

DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
HOMEPAGE="https://github.com/jedisct1/libsodium"
SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"

LICENSE="ISC"
SLOT="0/18"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+asm minimal static-libs +urandom"

src_configure() {
local myconf

# --disable-pie needed on x86, bug #512734
use x86 && myconf="${myconf} --disable-pie"

econf \
$(use_enable asm) \
$(use_enable minimal) \
$(use_enable !urandom blocking-random) \
$(use_enable static-libs static) \
${myconf}
}

src_install() {
default
prune_libtool_files
}

0 comments on commit 0b5a5b4

Please sign in to comment.