Skip to content

Commit

Permalink
games-misc/c++robots: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Oct 11, 2016
1 parent 2e52ea0 commit 0b609ec
Showing 1 changed file with 31 additions and 0 deletions.
31 changes: 31 additions & 0 deletions games-misc/c++robots/c++robots-0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

DESCRIPTION="ongoing 'King of the Hill' (KotH) tournament"
HOMEPAGE="http://www.gamerz.net/c++robots/"
SRC_URI="http://www.gamerz.net/c++robots/c++robots.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE="static"

S=${WORKDIR}/${PN}

PATCHES=(
"${FILESDIR}/proper-coding.patch"
)

src_compile() {
local myldflags="${LDFLAGS}"
use static && myldflags="${myldflags} -static"
emake CFLAGS="${CFLAGS}" LDFLAGS="${myldflags}"
}

src_install() {
dobin combat cylon target tracker
dodoc README
}

0 comments on commit 0b609ec

Please sign in to comment.