Skip to content

Commit

Permalink
dev-lang/coffee-script: add version 1.10.0.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
orlitzky committed Nov 18, 2015
1 parent c8d023d commit 0b64a5b
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/coffee-script/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST coffee-script-1.10.0.tar.gz 813684 SHA256 1747a315002e69c2d459c2e618ac51d13b383a37792f05bdab155b3c943d2ef2 SHA512 4bf6d3e396a3c5eb2b4eb385216ed930f09a3b6d88c3939813ceea21c32b18706640f73d75619528d5ef12a90888e713385ecabbb8d424c06f52eb71e88230ec WHIRLPOOL 216652595821cad1f0c388ff614ceab48de4cec6669f6da98e0607ae94ae16960071d2e18d060b7c6ebd6035dc515f5c0f418940826555752320d672714d0d21
DIST coffee-script-1.9.3.tar.gz 810246 SHA256 8c8faeeee21ed3cdde727fcc08ed6062d9d0233679317f026160aee8bfa85060 SHA512 660826e27f842ed67ec6ef59f734087c95585e03b6b8c6d25c8ecfc567f3161f59034e730b61e5f806edaaa7ec6c805ad6d14902857aaf09cf6193b0fe14f506 WHIRLPOOL c99eab68344609b5352ee7b7f59ebb4e6c90d1454c3cf37ac8cb00b1add0637e2e56084864ae54cdeb494a6966a97e896bf95760e1e8dbe1b26c0fc75abd5a41
44 changes: 44 additions & 0 deletions dev-lang/coffee-script/coffee-script-1.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit multilib

MY_PN="coffeescript"

DESCRIPTION="A little language that compiles into javascript"
HOMEPAGE="http://coffeescript.org/"
SRC_URI="https://github.com/jashkenas/${MY_PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

# This package has a test suite (that works), but it requires a number
# of NodeJS/NPM packages that aren't in the tree.
IUSE="doc examples"

RDEPEND="net-libs/nodejs"

src_install(){
local npm_module_dir="/usr/$(get_libdir)/node/${PN}"
insinto "${npm_module_dir}"
doins *.js package.json
doins -r lib
dodoc CONTRIBUTING.md README.md

use doc && dodoc -r documentation
use examples && dodoc -r examples

# The coffee and cake "binaries" use a relative path to find the lib
# directory, so we have to symlink them rather than use dobin().
exeinto "${npm_module_dir}/bin"
doexe bin/cake
doexe bin/coffee
dosym "${npm_module_dir}/bin/cake" "/usr/bin/cake"
dosym "${npm_module_dir}/bin/coffee" "/usr/bin/coffee"
}

0 comments on commit 0b64a5b

Please sign in to comment.