forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/salt: Bumps to fix bug#563508 and CVE-2015-6941
Drop `salt-2015.5.0-archive-test.patch` from salt-2015.5.6.ebuild (upstream fix in @81a0d4c9) Gentoo-Bug: 563508 CVE: CVE-2015-6941 - salt: win_useradd module and salt-cloud display passwords in debug log Package-Manager: portage-2.2.23
- Loading branch information
Showing
3 changed files
with
241 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,6 @@ | ||
DIST salt-2015.5.3.tar.gz 5389038 SHA256 f8b04dc8bd4b00ce803d31ce5fba033c2f20fa38cdc5a3bf54b4c47362fbe853 SHA512 61203cb9b82fe8ab84fa36d06f442aebcf5c5decfacb99f8df6b52320979699d168f9df7e9e675a13a8078feabbe9210a40e526627a213239760ea43d85f1298 WHIRLPOOL 160455263ee1a95faec1f03dfcd16f9b811e5ecb961a2db5c9545070ed74786c83592e008c1ed70a6ea358ba2491128d6081d57bf7c0a679bb99abb1555bbd21 | ||
DIST salt-2015.5.5.tar.gz 5526444 SHA256 5cd8d317616abab691a83f7fd3f8bcf9ad8aecaa95fcfdc0f6d788de87f0beeb SHA512 263f772d403c0e841957342f552389914c563add3f774f26b5d9da81efa04330ec95349223f81e192a2a4789b2d565f7a67e9e3be564296d6235a47cb6657ac3 WHIRLPOOL 7b4f71d6a12b50f4f0a92bfd68c1df2cf8992481d17db984079d4a9cadd51de56d7390ea69c9b02055e747993818756af85f82538a4640e5fb831e4a1ee1cb57 | ||
DIST salt-2015.5.6.tar.gz 5564414 SHA256 4fe478132ce84076b3e424cdd217443766d83ac40fa0ec0e914ca46111971c38 SHA512 6f091b2de8d5f949eb8df8d5173bc122b971a3966b3f4fa55209906dba83b744a72b24e40ee1b0b4dc0a51d740bc336e10798a310da3544e36d4d8585934ac11 WHIRLPOOL 2d25cfada4dab07e82dad6542ac8c290d55ca493fe90186af4b1f78b3684dcb7c9d95eab4a0fe22a0c82cb8b31e8176cc750ebab5304927bbbc7f2a2545ebc8b | ||
DIST salt-2015.8.0.tar.gz 6584668 SHA256 71e1cb2eb1d4b30f3247f5590c00a2089190b8f9a90c9330dc9a65fae517ec9b SHA512 e5066773cdd69635272e8bda4e030ae270ea0d6a4895ca18c2d8e94ae7a2987700fda05a760d799e369f1ec977428da0a1c8797790f0f9ac30c03a4d80ce1599 WHIRLPOOL ca1c1d8f18d29b047ebbdf590ed1d1bbe932359017505af2b5043aa6e5035756e29f9d7d3f9293ca5a76c6d643b38d62cedbc3abffafef7cf8ab2443f7143fe9 | ||
DIST salt-2015.8.1.tar.gz 6527650 SHA256 04133839b4632859ad696a40261d1d14b62902dbcaf7df2f9e5e926c89401c23 SHA512 d882e3a8e70cf19c64e14c35d4c69fa308b8502d01095ce3f8c383a0ee0b70dbefd4b8eda95205f2cba2fe237279e2a3425daf0d5bf66144fb97ca3be0ec162a WHIRLPOOL a1014b8b2b1f815e2f9981cf3c8696b151a4788afb5525021ad94a6d9da774870290ed94fa159b5e3d8f8c73a682417937a1c48b0431d009a21c1e89a32d61f0 | ||
DIST salt-vim-20141109.tar.gz 3783 SHA256 4989d111ad618ea3f5f7a7046a0ff6ce3ca6bc7f71fca90849f7c38947ab6d9a SHA512 d8d62ee827012e29586cf492f2881ee5870ed058828102f985e8b27300c115e01bb126f89decb15a19a8e206dc54c89856d4c31b3ff5320a36385cb5ed517a63 WHIRLPOOL 98026b2cdcb64665790475e3b20a7de294e5cefb390b414294756cad440bc040d9044ffd37a13f3c93af9be1a1bfd444710ff0df24895db624f49fddd16b5545 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,118 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=(python2_7) | ||
|
||
inherit eutils systemd vim-plugin distutils-r1 | ||
|
||
DESCRIPTION="Salt is a remote execution and configuration manager" | ||
HOMEPAGE="http://saltstack.org/" | ||
SALT_VIM_HASH="20695f68e5895e5ae2b5884b78f5a2cd29897b05" | ||
|
||
if [[ ${PV} == 9999* ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="git://github.com/${PN}stack/${PN}.git" | ||
EGIT_BRANCH="develop" | ||
SRC_URI="" | ||
KEYWORDS="" | ||
else | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
KEYWORDS="~x86 ~amd64" | ||
fi | ||
|
||
SRC_URI+=" vim-syntax? ( https://github.com/${PN}stack/${PN}-vim/archive/${SALT_VIM_HASH}.tar.gz -> salt-vim-20141109.tar.gz )" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="cherrypy ldap libcloud libvirt gnupg keyring mako mongodb mysql neutron nova" | ||
IUSE+=" openssl redis selinux test timelib raet +zeromq vim-syntax" | ||
|
||
RDEPEND="sys-apps/pciutils | ||
dev-python/jinja[${PYTHON_USEDEP}] | ||
>=dev-python/msgpack-0.3[${PYTHON_USEDEP}] | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
dev-python/markupsafe[${PYTHON_USEDEP}] | ||
>=dev-python/requests-1.0.0[${PYTHON_USEDEP}] | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
>=www-servers/tornado-4.0[${PYTHON_USEDEP}] | ||
libcloud? ( >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}] ) | ||
mako? ( dev-python/mako[${PYTHON_USEDEP}] ) | ||
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] ) | ||
openssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] ) | ||
libvirt? ( dev-python/libvirt-python[${PYTHON_USEDEP}] ) | ||
raet? ( | ||
>=dev-python/libnacl-1.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/ioflo-1.1.7[${PYTHON_USEDEP}] | ||
>=dev-python/raet-0.6.0[${PYTHON_USEDEP}] | ||
) | ||
zeromq? ( | ||
>=dev-python/pyzmq-2.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/m2crypto-0.22.3[${PYTHON_USEDEP}] | ||
dev-python/pycrypto[${PYTHON_USEDEP}] | ||
) | ||
cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] ) | ||
mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] ) | ||
keyring? ( dev-python/keyring[${PYTHON_USEDEP}] ) | ||
mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] ) | ||
redis? ( dev-python/redis-py[${PYTHON_USEDEP}] ) | ||
selinux? ( sec-policy/selinux-salt ) | ||
timelib? ( dev-python/timelib[${PYTHON_USEDEP}] ) | ||
nova? ( >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}] ) | ||
neutron? ( >=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}] ) | ||
gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )" | ||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/pip[${PYTHON_USEDEP}] | ||
dev-python/virtualenv[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/timelib[${PYTHON_USEDEP}] | ||
>=dev-python/boto-2.32.1[${PYTHON_USEDEP}] | ||
>=dev-python/moto-0.3.6[${PYTHON_USEDEP}] | ||
>=dev-python/SaltTesting-2015.2.16[${PYTHON_USEDEP}] | ||
${RDEPEND} | ||
)" | ||
|
||
DOCS=(README.rst AUTHORS) | ||
|
||
REQUIRED_USE="|| ( raet zeromq )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-2014.7.1-remove-pydsl-includes-test.patch" | ||
"${FILESDIR}/${PN}-2015.5.5-auth-tests.patch" | ||
"${FILESDIR}/${PN}-2015.5.5-cron-tests.patch" | ||
"${FILESDIR}/${PN}-2015.5.5-remove-buggy-tests.patch" | ||
) | ||
|
||
python_prepare() { | ||
# this test fails because it trys to "pip install distribute" | ||
rm tests/unit/{modules,states}/zcbuildout_test.py tests/unit/modules/{rh_ip,win_network}_test.py | ||
} | ||
|
||
python_install_all() { | ||
local svc | ||
USE_SETUPTOOLS=1 distutils-r1_python_install_all | ||
|
||
for svc in minion master syndic api; do | ||
newinitd "${FILESDIR}"/${svc}-initd-4 salt-${svc} | ||
newconfd "${FILESDIR}"/${svc}-confd-1 salt-${svc} | ||
systemd_dounit "${FILESDIR}"/salt-${svc}.service | ||
done | ||
|
||
insinto /etc/${PN} | ||
doins -r conf/* | ||
|
||
use vim-syntax && S="${WORKDIR}/salt-vim-${SALT_VIM_HASH}" \ | ||
vim-plugin_src_install | ||
} | ||
|
||
python_test() { | ||
# testsuite likes lots of files | ||
ulimit -n 3072 | ||
|
||
# using ${T} for the TMPDIR makes some tests needs paths that exceed PATH_MAX | ||
USE_SETUPTOOLS=1 SHELL="/bin/bash" TMPDIR="/tmp" \ | ||
${EPYTHON} tests/runtests.py \ | ||
--unit-tests --no-report --verbose || die "testing failed" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,121 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=(python2_7) | ||
|
||
inherit eutils systemd vim-plugin distutils-r1 | ||
|
||
DESCRIPTION="Salt is a remote execution and configuration manager" | ||
HOMEPAGE="http://saltstack.org/" | ||
SALT_VIM_HASH="20695f68e5895e5ae2b5884b78f5a2cd29897b05" | ||
|
||
if [[ ${PV} == 9999* ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="git://github.com/${PN}stack/${PN}.git" | ||
EGIT_BRANCH="develop" | ||
SRC_URI="" | ||
KEYWORDS="" | ||
else | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
KEYWORDS="~x86 ~amd64" | ||
fi | ||
|
||
SRC_URI+=" vim-syntax? ( https://github.com/${PN}stack/${PN}-vim/archive/${SALT_VIM_HASH}.tar.gz -> salt-vim-20141109.tar.gz )" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="cherrypy ldap libcloud libvirt gnupg keyring mako mongodb mysql neutron nova" | ||
IUSE+=" openssl profile redis selinux test timelib raet +zeromq vim-syntax" | ||
|
||
RDEPEND="sys-apps/pciutils | ||
dev-python/jinja[${PYTHON_USEDEP}] | ||
>=dev-python/msgpack-0.3[${PYTHON_USEDEP}] | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
dev-python/markupsafe[${PYTHON_USEDEP}] | ||
>=dev-python/requests-1.0.0[${PYTHON_USEDEP}] | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
>=www-servers/tornado-4.2.1[${PYTHON_USEDEP}] | ||
virtual/python-futures[${PYTHON_USEDEP}] | ||
libcloud? ( >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}] ) | ||
mako? ( dev-python/mako[${PYTHON_USEDEP}] ) | ||
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] ) | ||
openssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] ) | ||
libvirt? ( dev-python/libvirt-python[${PYTHON_USEDEP}] ) | ||
raet? ( | ||
>=dev-python/libnacl-1.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/ioflo-1.1.7[${PYTHON_USEDEP}] | ||
>=dev-python/raet-0.6.0[${PYTHON_USEDEP}] | ||
) | ||
zeromq? ( | ||
>=dev-python/pyzmq-2.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/pycrypto-2.6.1[${PYTHON_USEDEP}] | ||
) | ||
cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] ) | ||
mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] ) | ||
keyring? ( dev-python/keyring[${PYTHON_USEDEP}] ) | ||
mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] ) | ||
redis? ( dev-python/redis-py[${PYTHON_USEDEP}] ) | ||
selinux? ( sec-policy/selinux-salt ) | ||
timelib? ( dev-python/timelib[${PYTHON_USEDEP}] ) | ||
nova? ( >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}] ) | ||
neutron? ( >=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}] ) | ||
gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] ) | ||
profile? ( dev-python/yappi[${PYTHON_USEDEP}] )" | ||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/pip[${PYTHON_USEDEP}] | ||
dev-python/virtualenv[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/timelib[${PYTHON_USEDEP}] | ||
>=dev-python/boto-2.32.1[${PYTHON_USEDEP}] | ||
>=dev-python/moto-0.3.6[${PYTHON_USEDEP}] | ||
>=dev-python/SaltTesting-2015.2.16[${PYTHON_USEDEP}] | ||
${RDEPEND} | ||
)" | ||
|
||
DOCS=(README.rst AUTHORS) | ||
|
||
REQUIRED_USE="|| ( raet zeromq )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-2015.8.0-remove-pydsl-includes-test.patch" | ||
"${FILESDIR}/${PN}-2015.8.0-remove-buggy-tests.patch" | ||
"${FILESDIR}/${PN}-2015.5.5-auth-tests.patch" | ||
"${FILESDIR}/${PN}-2015.5.5-cron-tests.patch" | ||
"${FILESDIR}/${PN}-2015.5.5-remove-buggy-tests.patch" | ||
) | ||
|
||
python_prepare() { | ||
# this test fails because it trys to "pip install distribute" | ||
rm tests/unit/{modules,states}/zcbuildout_test.py \ | ||
tests/unit/modules/{rh_ip,win_network,random_org}_test.py | ||
} | ||
|
||
python_install_all() { | ||
local svc | ||
USE_SETUPTOOLS=1 distutils-r1_python_install_all | ||
|
||
for svc in minion master syndic api; do | ||
newinitd "${FILESDIR}"/${svc}-initd-4 salt-${svc} | ||
newconfd "${FILESDIR}"/${svc}-confd-1 salt-${svc} | ||
systemd_dounit "${FILESDIR}"/salt-${svc}.service | ||
done | ||
|
||
insinto /etc/${PN} | ||
doins -r conf/* | ||
|
||
use vim-syntax && S="${WORKDIR}/salt-vim-${SALT_VIM_HASH}" \ | ||
vim-plugin_src_install | ||
} | ||
|
||
python_test() { | ||
# testsuite likes lots of files | ||
ulimit -n 3072 | ||
|
||
# using ${T} for the TMPDIR makes some tests needs paths that exceed PATH_MAX | ||
USE_SETUPTOOLS=1 SHELL="/bin/bash" TMPDIR="/tmp" \ | ||
${EPYTHON} tests/runtests.py \ | ||
--unit-tests --no-report --verbose || die "testing failed" | ||
} |