Skip to content

Commit

Permalink
gnome-base/nautilus: Version bump to 45_beta
Browse files Browse the repository at this point in the history
Closes: gentoo#32263
Signed-off-by: Guillermo Joandet <[email protected]>
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
flint2 authored and mattst88 committed Aug 16, 2023
1 parent b83f601 commit 0b713ad
Show file tree
Hide file tree
Showing 2 changed files with 123 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/nautilus/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST nautilus-44.1.tar.xz 3192400 BLAKE2B dfd02c6cdd23a723ba65a93953e80a859a22c6104cb1faeb24a81d9031b99ffc4cc9b3dd10743f928b36da3bf7c33500dc23f9f37530845b54cb250660513b9c SHA512 fa7c029db1c8c7e13d22e692e4e107dbadb136aa8313de1bc07b826bf681af012d9a4a70c3ad4def0f348b2acb103455edcb2f7b1c804f525e337b4417fb6db2
DIST nautilus-44.2.1.tar.xz 3190824 BLAKE2B 159abd8fbaea3f372febb4c7f68f95d97b50ac19e31d6108c9588aa849f92ea82a2a04402c8ee78f223339ffe929ed3fc95e4606db7753adacf6edb49f340910 SHA512 35974f9d2d785c69d4199287f1b79aa83397b37b3ad3ebe97894ee5e5d9aa4a981808fa443d5c04d2c7223c290a2cad87e3eeb62787b1d241486c39d5e061769
DIST nautilus-45.alpha.tar.xz 3195844 BLAKE2B d320a4e120d9d7d090edbdfd21fc029f4b54ca6bdbde78025f7c9c4e46b09f3aac335339d92507bf5f2db1c9cd74a33e9bbfbe0579d6edf22b05e352c8d052b3 SHA512 7d3635ca65502fe272258771916613681f2969296a810b1c2c0e5192e8a4f54f05d9dd4a06fbc5d17d68e5158b5111c5edf272daaf4e0f3d582f3db4fc817ace
DIST nautilus-45.beta.tar.xz 3202420 BLAKE2B 5971d32df4a904f1f15267b0a2c1578ab392e37a2e28c6d4a1599d9e841e4feb88fd0aa9a5eed4960d2c4d777d1accaddfecbfc57aba5896895ba74ecd0effc9 SHA512 8ded32923ec1503d43258cc6938eb391a5eb871854a290bd78a13471ba426af7a9323f5ba163956985f43d36cf94d3474cdd2b8e852b6b89ce5395995dd06379
122 changes: 122 additions & 0 deletions gnome-base/nautilus/nautilus-45_beta.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,122 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit gnome.org gnome2-utils meson readme.gentoo-r1 virtualx xdg

DESCRIPTION="Default file manager for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"

LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
IUSE="+cloudproviders gnome +gstreamer gtk-doc +introspection +previewer selinux sendto"
REQUIRED_USE="gtk-doc? ( introspection )"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"

DEPEND="
>=dev-libs/glib-2.77.0:2
>=media-libs/gexiv2-0.14.0
>=x11-libs/gdk-pixbuf-2.30.0:2
gstreamer? ( media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0 )
>=app-arch/gnome-autoar-0.4.4
>=gnome-base/gnome-desktop-43:4=
>=gnome-base/gsettings-desktop-schemas-42
>=gui-libs/gtk-4.11.2:4[introspection?]
>=gui-libs/libadwaita-1.4_alpha:1
>=dev-libs/libportal-0.5:=[gtk]
>=x11-libs/pango-1.28.3
selinux? ( >=sys-libs/libselinux-2.0 )
>=app-misc/tracker-3.0:3
>=dev-libs/libxml2-2.7.8:2
cloudproviders? ( >=net-libs/libcloudproviders-0.3.1 )
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
"
RDEPEND="${DEPEND}
>=app-misc/tracker-miners-3.0:3=
" # uses org.freedesktop.Tracker.Miner.Files gsettings schema from tracker-miners
BDEPEND="
>=dev-util/gdbus-codegen-2.51.2
dev-util/glib-utils
gtk-doc? (
app-text/docbook-xml-dtd:4.1.2
dev-util/gi-docgen
)
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
test? ( sys-apps/dbus )
"
PDEPEND="
gnome? ( x11-themes/adwaita-icon-theme )
previewer? ( >=gnome-extra/sushi-0.1.9 )
sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
>=gnome-base/gvfs-1.14[gtk(+)]
" # Need gvfs[gtk] for recent:/// support; always built (without USE=gtk) since gvfs-1.34

PATCHES=(
"${FILESDIR}"/43.0-optional-gstreamer.patch # Allow controlling audio-video-properties build
)

src_prepare() {
default
xdg_environment_reset

# Disable -Werror
sed -e '/-Werror=/d' -i meson.build || die

if use previewer; then
DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
To activate the previewer, select a file and press space; to
close the previewer, press space again."
fi

# Disable test-nautilus-search-engine-tracker; bug #831170
sed -e '/^tracker_tests = /{n;N;N;d}' -i test/automated/displayless/meson.build || die
}

src_configure() {
local emesonargs=(
$(meson_use gtk-doc docs)
-Dextensions=true # image file properties, sendto support; also required for -Dgstreamer=true
$(meson_use introspection)
-Dpackagekit=false
$(meson_use selinux)
$(meson_use cloudproviders)
-Dprofiling=false
-Dtests=$(usex test all none)

$(meson_use gstreamer) # gstreamer audio-video-properties extension
)
meson_src_configure
}

src_install() {
use previewer && readme.gentoo_create_doc
meson_src_install
}

src_test() {
# Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
gnome2_environment_reset
# TODO: Tests require tracker testutils (e.g. tracker-sandbox), which may
# need some sorting out with tracker use flag deps
XDG_SESSION_TYPE=x11 virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update

if use previewer; then
readme.gentoo_print_elog
else
elog "To preview media files, emerge nautilus with USE=previewer"
fi
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}

0 comments on commit 0b713ad

Please sign in to comment.