Skip to content

Commit

Permalink
app-eselect/eselect-php: call tmpfiles_process() in pkg_postinst().
Browse files Browse the repository at this point in the history
With USE=fpm, we install a tmpfiles entry that needs to be processed
immediately, before php-fpm is launched. This commit adds the necessary
call to the -9999 ebuild in pkg_postinst() when USE=fpm is set.

We make the same change in a new revision 0.9.7-r1, but there I've
also created a proper release tarball upstream (on my devspace) so
that we can drop the autotools.eclass inherit.

Closes: https://bugs.gentoo.org/808588
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Michael Orlitzky <[email protected]>
  • Loading branch information
orlitzky committed Aug 17, 2021
1 parent 233f8bf commit 0b7f7e7
Show file tree
Hide file tree
Showing 3 changed files with 44 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-eselect/eselect-php/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST eselect-php-0.9.6.tar.xz 53236 BLAKE2B 38478d4792f8a527e5f519abd7765211aff8c1d132ceeba5eec70ea3b8d1f254be52564334fed3840950c2461ff4a30784b92fbb8b21cc448083617797eab1d4 SHA512 d3f14288b3493cb48717c1f27430ae8b60881e9f6f48e4b7644a4596d9fc1b9823a6af8b7101a62b28a92e3bff164b1717617a2642a5bb02e8dd46de56d4f410
DIST eselect-php-0.9.7.tar.bz2 8460 BLAKE2B 160c87d1373b10cb2bd2d48210c7382f721433fb45557d0a5336af0ea25a1a49b151bcbbcf253947e6a5018b5740e8f9f9b1a66544bd74539a4e54aeab047a74 SHA512 f6c909906228906bc75be24bdf69330db10b0ea84822a5a016a185ac2855eec34bf6cb0bdaf22f3edc331002e72c8ae56733e1ea13cf815948a7a58439240fa9
DIST eselect-php-0.9.7.tar.xz 54124 BLAKE2B e704935046687de6aa52d1900c207a48c79bcb0122506d001bf63ebb76b8144f19b2439daa34fd8da942a5eb4ce942e9b5562e5446ba5b7f62c247470c72018b SHA512 9f4ec72e6ca82fc0d9652f8f55d8bb626dd04a2881cb74d6c63db7ac095ed8ae170fe33ed34a4a76afc9a436114ad23c6981c0dad5afdce8f09c9c0026163bed
37 changes: 37 additions & 0 deletions app-eselect/eselect-php/eselect-php-0.9.7-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit tmpfiles

DESCRIPTION="PHP eselect module"
HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="fpm apache2"

# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
RDEPEND="app-admin/eselect
apache2? ( www-servers/apache[apache2_modules_dir] )"

src_configure() {
# We expect localstatedir to be "var"ish, not "var/lib"ish, because
# that's what PHP upstream expects. See for example the FPM
# configuration where they put logs in @localstatedir@/log.
#
# The libdir is passed explicitly in case the /usr/lib symlink
# is not present (bug 624528).
econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
--localstatedir="${EPREFIX}/var" \
--with-piddir="${EPREFIX}/run" \
$(use_enable apache2) \
$(use_enable fpm)
}

pkg_postinst() {
use fpm && tmpfiles_process php-fpm.conf
}
8 changes: 6 additions & 2 deletions app-eselect/eselect-php/eselect-php-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit git-r3 autotools
inherit autotools git-r3 tmpfiles

DESCRIPTION="PHP eselect module"
HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
Expand Down Expand Up @@ -36,3 +36,7 @@ src_configure() {
$(use_enable apache2) \
$(use_enable fpm)
}

pkg_postinst() {
use fpm && tmpfiles_process php-fpm.conf
}

0 comments on commit 0b7f7e7

Please sign in to comment.