Skip to content

Commit

Permalink
media-gfx/openvdb: revision bump to 4.0.2-r2
Browse files Browse the repository at this point in the history
Remove unused inherit in 4.0.2 ebuild

Fixed unittests and add test use flag

Fixed boost linker errors

removed unused option as it was Win32 only
Closes: https://bugs.gentoo.org/660278

Update manifest for upcoming v5 release and fix descriptions
Closes: gentoo#9535
  • Loading branch information
dracwyrm committed Aug 14, 2018
1 parent 28b5bdb commit 0ba534f
Show file tree
Hide file tree
Showing 5 changed files with 97 additions and 9 deletions.
1 change: 1 addition & 0 deletions media-gfx/openvdb/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST openvdb-4.0.2-patchset-01.tar.xz 16420 BLAKE2B 2f825532d83d3a6756454f164a0608cfa776c1d4472cb4b25e4dad20d3c9648a952deef87ed0e24ce5f7c927c02da8cca76c829eafe1e2bb47fca061541668b3 SHA512 e9399d245d5e2b4130576d688691ac965f031b957df7803b8859f863634b27987c33aabadc5fb463b9d3eec333be84b89cb619dce5bc81c0390d8fb19da830c3
DIST openvdb-4.0.2-patchset-02.tar.xz 12428 BLAKE2B 2684ddf010df975912fcfc8c4f944d9a9ba447b48750140b6c46db31d49297f7495e5c77e9d5b85af0b2e1d0c4987184865642dc95f1fb3e463e85ee5987d203 SHA512 04377d552e218a8eb31c43381ba32263ba206a0870dccda1bcc031863dfdbcc953da7ea89fd420dc1a338fbd6123ac30bac2039c0a2a01c1fa9253a3fdd0b54d
DIST openvdb-4.0.2.tar.gz 1689119 BLAKE2B dbc8d4ab44990440e201327d76bbf9bfe3e8f597505b1d008dedb95dc540277513f465d455079c59820acc5056c9a2edf56235e1097b6c73a1f7dd8c59609c15 SHA512 8e3e12583b81f9b9303b309e839c8321c67b67ff8a0e61bb56c87276bf25c0deff22f5a73c7c5b661b8e5df345bfdabfa6b0aea9bf16fce57d9c53a76751c75d
16 changes: 13 additions & 3 deletions media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch
Original file line number Diff line number Diff line change
@@ -1,11 +1,21 @@
--- openvdb-4.0.2/openvdb/python/CMakeLists.txt.orig 2018-07-12 20:29:50.745624805 +0200
+++ openvdb-4.0.2/openvdb/python/CMakeLists.txt 2018-07-12 20:30:10.452305180 +0200
diff -urN a/openvdb/python/CMakeLists.txt b/openvdb/python/CMakeLists.txt
--- a/openvdb/python/CMakeLists.txt 2017-07-31 19:16:32.000000000 +0100
+++ b/openvdb/python/CMakeLists.txt 2018-08-11 12:37:40.179360277 +0100
@@ -3,7 +3,7 @@

FIND_PACKAGE ( PythonInterp REQUIRED )
FIND_PACKAGE ( PythonLibs REQUIRED )
-FIND_PACKAGE ( Boost ${MINIMUM_BOOST_VERSION} REQUIRED COMPONENTS python )
+FIND_PACKAGE ( Boost ${MINIMUM_BOOST_VERSION} REQUIRED COMPONENTS python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR} )
+FIND_PACKAGE ( Boost ${MINIMUM_BOOST_VERSION} REQUIRED COMPONENTS python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} )


IF ( NOT OPENVDB_BUILD_CORE )
@@ -92,7 +92,7 @@
${GLFW_LINK_LIBRARY}
${GLFW_DEPENDENT_LIBRARIES}
${GLEW_GLEW_LIBRARY}
- ${Boost_PYTHON_LIBRARY}
+ ${Boost_LIBRARIES}
${PYTHON_LIBRARY}
${Ilmbase_HALF_LIBRARY}
)
9 changes: 4 additions & 5 deletions media-gfx/openvdb/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer restrict="&gt;=media-gfx/openvdb-3.1.0" type="person">
<maintainer type="person">
<email>[email protected]</email>
<name>Jonathan Scruggs</name>
</maintainer>
<maintainer restrict="&gt;=media-gfx/openvdb-3.1.0" type="person">
<maintainer type="person">
<email>[email protected]</email>
<name>Adrian Grigo</name>
</maintainer>
Expand All @@ -19,9 +19,8 @@
Chance of Meatballs2' and 'How to Train Your Dragon 2'.
</longdescription>
<use>
<flag restrict="&gt;=media-gfx/openvdb-4.0.0" name="abi3-compat">
Enables compatibility with the old 3.x ABI.
enabled by dfault.
<flag restrict="&lt;media-gfx/openvdb-5.0.0" name="abi3-compat">
Disables newer features to maintain compatibility with ABI3. Enabled by default.
</flag>
</use>
<upstream>
Expand Down
78 changes: 78 additions & 0 deletions media-gfx/openvdb/openvdb-4.0.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit cmake-utils flag-o-matic python-single-r1

DESCRIPTION="Libs for the efficient manipulation of volumetric data"
HOMEPAGE="http://www.openvdb.org"
SRC_URI="https://github.com/dreamworksanimation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://dev.gentoo.org/~dracwyrm/patches/${P}-patchset-02.tar.xz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+abi3-compat doc python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="
>=dev-libs/boost-1.62:=[python?,${PYTHON_USEDEP}]
>=dev-libs/c-blosc-1.5.0
dev-libs/jemalloc
dev-libs/log4cplus
media-libs/glfw:=
media-libs/openexr:=
sys-libs/zlib:=
x11-libs/libXcursor
x11-libs/libXi
x11-libs/libXinerama
x11-libs/libXrandr
python? (
${PYTHON_DEPS}
dev-python/numpy[${PYTHON_USEDEP}]
)"

DEPEND="${RDEPEND}
dev-cpp/tbb
virtual/pkgconfig
doc? ( app-doc/doxygen[latex] )
test? ( dev-util/cppunit )"

PATCHES=(
"${WORKDIR}/${P}-patchset-02/0001-use-gnuinstalldirs.patch"
"${WORKDIR}/${P}-patchset-02/0002-use-pkgconfig-for-ilmbase-and-openexr.patch"
"${WORKDIR}/${P}-patchset-02/0003-boost-1.65-numpy-support.patch"
"${FILESDIR}/${P}-findboost-fix.patch"
)

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_configure() {
local myprefix="${EPREFIX}/usr/"

# To stay in sync with Boost
append-cxxflags -std=c++14

local mycmakeargs=(
-DBLOSC_LOCATION="${myprefix}"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DGLFW3_LOCATION="${myprefix}"
-DOPENVDB_BUILD_DOCS=$(usex doc)
-DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
-DOPENVDB_BUILD_UNITTESTS=$(usex test)
-DOPENVDB_ENABLE_3_ABI_COMPATIBLE=$(usex abi3-compat)
-DOPENVDB_ENABLE_RPATH=OFF
-DTBB_LOCATION="${myprefix}"
-DUSE_GLFW3=ON
)

use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
use test && mycmakeargs+=( -DCPPUNIT_LOCATION="${myprefix}" )

cmake-utils_src_configure
}
2 changes: 1 addition & 1 deletion media-gfx/openvdb/openvdb-4.0.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit cmake-utils flag-o-matic python-single-r1 versionator
inherit cmake-utils flag-o-matic python-single-r1

DESCRIPTION="Libs for the efficient manipulation of volumetric data"
HOMEPAGE="http://www.openvdb.org"
Expand Down

0 comments on commit 0ba534f

Please sign in to comment.