Skip to content

Commit

Permalink
dev-games/clanlib: add 4.1.0
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jun 13, 2021
1 parent 6e7806f commit 0bd563a
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-games/clanlib/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ClanLib-0.8.1.tgz 7629019 BLAKE2B 7f238111931212e3f9c82ed43842706bf16ee145896735ca35595e29dd357e52364cc592be55d88e231f962adc313bc8f57357bc74c9f1b8b134bc411497f5e9 SHA512 277daaf1055ae0198be7a6bbfd415c79cfae9e2145f62553e83849d670f56e50b8484c83f8b85f23290002e0b0c72c1e01ca597ad608a0954a4add828177293b
DIST ClanLib-2.3.7.tgz 26132425 BLAKE2B 109ba92baf21174022c8dbc4044e39ec16ec77c730b57590733418e246ab71d18d81bbf281cd469dd9e2aebd4ac4302fbb581f27dc7fc0054a8c7ce69699e19d SHA512 73169afc0f639390f80403150757a8a14f842bc291a9457c9bca1319642b78bc4d03a93327d75254230e39545c5b4b690e56dc0149ed7b60b223e5a5364e882a
DIST clanlib-4.0.0.tar.gz 7435551 BLAKE2B 243fc2519ee90a12af37e8925c99db77785a9a5da497d870545bb489e76cbfcbb4cac81352731326a0cc59689a361b8ab14db2bb1e255da07696e378a9cfb6e5 SHA512 e727239d782d2d52ce2f927e16a88c469b30f46d5b9eba4573baa520d98f60515df7ff4dd921092ddd5cfe4c6f5c441e0f33469b774287003db439feb8b027fe
DIST clanlib-4.1.0.tar.gz 6871886 BLAKE2B 0aeb9e89998a9ef6975bf16a2e77f461e6415aacda9a26a5c0a9c6ec3c19a136a5f092c7866b60898251fbd6cb8aa7e96c86f6b87afb564824298fac77bf20c3 SHA512 34f5d1fdb7b071a218f081a6b06a6018a9c20cedc4c8500a9796be02d335f06fa148304379eeb1a35e08b9a734e504ceb490a6558a43d1611187bd97be01f4b0
77 changes: 77 additions & 0 deletions dev-games/clanlib/clanlib-4.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools toolchain-funcs

MY_PN=ClanLib

DESCRIPTION="Multi-platform game development library"
HOMEPAGE="https://github.com/sphair/ClanLib"
SRC_URI="https://github.com/sphair/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"

LICENSE="ZLIB"
SLOT="4.1"
KEYWORDS="~amd64 ~x86" #not big endian safe #82779
IUSE="cpu_flags_x86_sse2 doc examples ipv6 opengl sound static-libs X"
REQUIRED_USE="opengl? ( X )"

RDEPEND="
sys-libs/zlib
X? (
media-libs/freetype:2
media-libs/fontconfig
x11-libs/libX11
opengl? (
virtual/opengl
x11-libs/libXrender
)
)
sound? ( media-libs/alsa-lib )"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? (
app-doc/doxygen
dev-lang/perl
media-gfx/graphviz
)"

src_prepare() {
default
eautoreconf
}

src_configure() {
local myeconfargs=(
$(use_enable doc docs)
$(use_enable cpu_flags_x86_sse2 sse2)
$(use_enable opengl clanGL)
$(use_enable opengl clanUI)
$(use_enable X clanDisplay)
$(use_enable sound clanSound)
$(use_enable ipv6 getaddr)
$(use_enable static-libs static)
)

tc-export PKG_CONFIG

econf "${myeconfargs[@]}"
}

src_compile() {
default
use doc && emake html
}

src_install() {
default

use doc && emake DESTDIR="${D}" install-html
use examples && dodoc -r Examples Resources

# package provides .pc files
find "${ED}" -name '*.la' -delete || die
}

0 comments on commit 0bd563a

Please sign in to comment.