Skip to content

Commit

Permalink
dev-util/pkgcheck: version bump
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Aug 24, 2015
1 parent 0bd25f7 commit 0bf1603
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/pkgcheck/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pkgcheck-0.5.1.tar.gz 68345 SHA256 2600434febcb5e6eb5bfb87f8d5c1106a4d301dffbe46b4aecb48773c3817342 SHA512 4187f1f19f9e30ecf9c0b7ef34dfecee3257860cbac1f8a3b3f14dc4ed6c8a81ecd4e4a62eac2a08c1fee81aa776d303e267e2c586034e4dcd3c019d1710789e WHIRLPOOL d9e07fd5ecc813bedc1c3d5ae936e672ed81105aed4c200aeb50e9ebad0fa068e4dba9a1dcf6d31a0b1c359510fddd5d80aa9663e7ad3d721c60186f55bec1d0
DIST pkgcheck-0.5.tar.gz 68669 SHA256 38de9d6ff6950852167f7d21b1aa50aab3b980150f9c31f2d0547e74165df7b9 SHA512 fb16450374b942533f83f76114c09e692ba000e91f79fb5e6a79afbfa791476864a591f1342e8b93fcbcc36422218a89b8e6753c65fdc644847ec1c08d369ace WHIRLPOOL 0fb7ac1b82fe58497cf41426d6ea11104e80900bc4f1378613c36022f93ea4f222c5324725475b3bdf5e91cb6048a17720bbaa7bba996407693a21f73cc34424
45 changes: 45 additions & 0 deletions dev-util/pkgcheck/pkgcheck-0.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
inherit git-r3
else
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi

DESCRIPTION="pkgcore-based QA utility"
HOMEPAGE="https://github.com/pkgcore/pkgcheck"

LICENSE="|| ( BSD GPL-2 )"
SLOT="0"

RDEPEND=">=sys-apps/pkgcore-0.9.2[${PYTHON_USEDEP}]
>=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"

pkg_setup() {
# disable snakeoil 2to3 caching...
unset PY2TO3_CACHEDIR
}

python_test() {
esetup.py test
}

python_install_all() {
local DOCS=( AUTHORS NEWS.rst )
distutils-r1_python_install_all
}

pkg_postinst() {
einfo "updating pkgcore plugin cache"
python_foreach_impl pplugincache pkgcheck.plugins
}

0 comments on commit 0bf1603

Please sign in to comment.