Skip to content

Commit

Permalink
dev-java/jline: Bump dev-java/jansi SLOT from 1.11 to 0.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Oct 17, 2015
1 parent e6a22f2 commit 0bf259f
Showing 1 changed file with 60 additions and 0 deletions.
60 changes: 60 additions & 0 deletions dev-java/jline/jline-2.12.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="A Java library for handling console input"
HOMEPAGE="https://github.com/jline/jline2"
SRC_URI="https://github.com/jline/${PN}/archive/${P}.tar.gz"

LICENSE="BSD"
SLOT="2"
KEYWORDS="~amd64 ~x86"
IUSE="test"

CDEPEND="dev-java/jansi:0
dev-java/jansi-native:0"

DEPEND="${CDEPEND}
>=virtual/jdk-1.6
test? ( dev-java/junit:4 )"

RDEPEND="${CDEPEND}
>=virtual/jre-1.6"

S="${WORKDIR}/${PN}2-${P}"

JAVA_SRC_DIR="src/main/java"
JAVA_GENTOO_CLASSPATH="jansi,jansi-native"

java_prepare() {
# Easier to use java-pkg-simple.
rm -v pom.xml || die

# Don't forget the resources!
mkdir -p target/classes || die
cp -r src/main/resources/* target/classes || die
}

src_install() {
java-pkg-simple_src_install

dodoc {CHANGELOG,README}.md
}

src_test() {
cd src/test/java || die

local CP=".:../resources:${S}/${PN}.jar:$(java-pkg_getjars junit-4,${JAVA_GENTOO_CLASSPATH})"
local TESTS=$(find * -name "*Test.java")
TESTS="${TESTS//.java}"
TESTS="${TESTS//\//.}"

ejavac -cp "${CP}" -d . $(find * -name "*.java")
ejunit4 -classpath "${CP}" ${TESTS}
}

0 comments on commit 0bf259f

Please sign in to comment.