Skip to content

Commit

Permalink
dev-ruby/httparty: add 0.15.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
graaff committed Feb 9, 2018
1 parent f6861ba commit 0bf7ed7
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/httparty/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST httparty-0.14.0.gem 84992 BLAKE2B 5fdb305a01c6c16bd8c9ea7bd11f0dddcb39a4bc3113b1e7ca83965f44b3462a41acaf1020e12e91b323d16ce27b65f2ea6f7d9e62722fbcecadc4d61dfd433c SHA512 db04caaeff3277c071a2d3914f782f9151597d601a2f8817e704c977b95b149144c47df73284f83396ce1099f75f7fdc3caaa17385a515878366e2b3fcb84b04
DIST httparty-0.15.5.gem 87552 BLAKE2B b5505b08ec91986da860d998a49b277e86151cb4a044a58d8c392bff65549170fb31ab3d7055772d18dcda690ce40962f9b8fce66a5c933093add93fc8364894 SHA512 c325a1b927e2b472c17b0895f322399e14f4beafe21626b4221a4a37ceb68cd3e92d801675a559d18cebc299f6317096b58bddecc59f687546ed88f284789459
DIST httparty-0.15.6.gem 87552 BLAKE2B edbaf27c17d423e8bcc13744f7b567953c4486e41fbd91442261bc2981a46385dcbcbf10b62c63a6ed713cf5ffb38287be6afcc1af1ebbde8365e1920eec9341 SHA512 2c38cd0a20cccd03c33e521ca683c4c2eaf487acef00d4cab244898bb227bf05e21e5f01a9641869635391ad052fc1d79d63c46fce0e09a96908b4e5aa8ec571
DIST httparty-0.15.7.gem 87552 BLAKE2B d7a0907d1c24113c129493a57ca900f45026e1ed7cc4407ac367d8ba5afa615af31496a2003755951d52672bdecd0646aaaf407b3c47d4856c9c492e7ec5cac7 SHA512 6bdf5946bc0f22afed346091078dd43dd62cb6190b3d01bc0de5c9732c611474e207c38b4c6eca5f3cc1e2139880c2eac19554d359dac861de33c5c5ceb28c5e
49 changes: 49 additions & 0 deletions dev-ruby/httparty/httparty-0.15.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby22 ruby23 ruby24"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"

inherit ruby-fakegem

DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
HOMEPAGE="https://jnunemaker.github.com/httparty"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

ruby_add_rdepend '>=dev-ruby/multi_xml-0.5.2'

ruby_add_bdepend 'test? ( dev-ruby/webmock )'

all_ruby_prepare() {
# Remove bundler
rm Gemfile || die
sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die

# Avoid test dependency on cucumber. We can't run the features since
# they depend on mongrel which is no longer packaged.
sed -i -e '/cucumber/I s:^:#:' Rakefile || die

# Avoid test dependency on simplecov
sed -i -e '/simplecov/I s:^:#:' \
-e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die

# Avoid test that works standalone but fails in the suite
sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
}

all_ruby_install() {
all_fakegem_install

docinto examples
dodoc examples/*
}

0 comments on commit 0bf7ed7

Please sign in to comment.