Skip to content

Commit

Permalink
dev-cpp/libjson-rpc-cpp: Bump to 0.7.0
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Aug 13, 2016
1 parent a51e247 commit 0bfd0fb
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/libjson-rpc-cpp/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libjson-rpc-cpp-0.5.0.tar.gz 124494 SHA256 e6d8d6c20517bb38eba9dba7f372e0a95432c4cbf55ec9b136ba841faa0a6d99 SHA512 9929f76899186f62d3201d3c884a4557e3bd55acfe0533b9a0cf543e01e6d2e5972239df7425c1a43bd59fd205261b91796fdaa1ab54b55cb5765250e473d2d4 WHIRLPOOL 95b51bdfd86e63e84556c490281829d211d937cb30a503b863180cac4a2a0894eb03ed931511e9336903f1ddad6b899921e1e09663af9cc0e5739569ddc14472
DIST libjson-rpc-cpp-0.6.0.tar.gz 130091 SHA256 98baf15e51514339be54c01296f0a51820d2d4f17f8c9d586f1747be1df3290b SHA512 8ad4e30b9ff8b53bde1671067ef6108d0a26a40d3925b2002c2aad9d66a17a51b1ea23b7ce278bcb56a992ff4c9a4616494d62dfe992c7db38341b449e88c777 WHIRLPOOL 0d6b75a29f84386086f070bb1a40e45d02f19dee567c9bd492d61aff84b470aed4d0b83879cfddb13e5109ad5d57a055f9b23b66016eb4319ed7dacd89da8474
DIST libjson-rpc-cpp-0.7.0.tar.gz 141665 SHA256 669c2259909f11a8c196923a910f9a16a8225ecc14e6c30e2bcb712bab9097eb SHA512 f7547271040382cd2ac96a31eb81d891b016e4d0c33a3ba3e659c2de2e55136e7e243dd2d959c6d8a64ccba7ebd9f9e28070d710a6770c29f81c0750ffad9e3a WHIRLPOOL b54121c95f47654a36623c4267a22f4d563bc6f863b2df205b1ea4142a8230e64e5fc0725f8e8cef7d79abdfdad5de118464993b6b503ff2cec9f4e077014201
53 changes: 53 additions & 0 deletions dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit cmake-utils

DESCRIPTION="JSON-RPC (1.0 & 2.0) framework for C++"
HOMEPAGE="https://github.com/cinemast/libjson-rpc-cpp"
SRC_URI="https://github.com/cinemast/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc +http-client +http-server +stubgen test"

RDEPEND="
dev-libs/jsoncpp:=
http-client? ( net-misc/curl:= )
http-server? ( net-libs/libmicrohttpd:= )
stubgen? ( dev-libs/argtable:= )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( dev-cpp/catch )"

RESTRICT="!test? ( test )"

src_configure() {
local mycmakeargs=(
-DHTTP_CLIENT=$(usex http-client)
-DHTTP_SERVER=$(usex http-server)
# they are not installed
-DCOMPILE_EXAMPLES=OFF
-DCOMPILE_STUBGEN=$(usex stubgen)
-DCOMPILE_TESTS=$(usex test)
-DCATCH_INCLUDE_DIR="${EPREFIX}/usr/include/catch"
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile

use doc && emake -C "${BUILD_DIR}" doc
}

src_install() {
cmake-utils_src_install

use doc && dodoc -r "${BUILD_DIR}"/doc/html
}

0 comments on commit 0bfd0fb

Please sign in to comment.