forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/genymotion-bin: bump version to 3.1.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Marco Genasci <[email protected]> Bug: https://bugs.gentoo.org/737680 Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
1 parent
51801ad
commit 0c1cba7
Showing
2 changed files
with
127 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST genymotion-3.1.0-linux_x64.bin 40490397 BLAKE2B 4601ff24b5cc2f33c442ec6cf76e04eaa010304d4097b30ac82c7d6824dc3949b409ec5867cc7f08ee2985e254eefc9d8282ff77a5a92961dec0df9f3f80c6d7 SHA512 53a325b0a7eac6998ae525277d3a566ab6a73e21eccd6496caecefc175138b604a516d2bba1fac9f61ad52aaf9dcf0dd1fe2cd2da0c5c31a2f48c08f88a2a68a | ||
DIST genymotion-3.1.1-linux_x64.bin 40506791 BLAKE2B 5318568766826cac587802c3b84fb2d32eaad6f00e0c2642fc1f8a81794f94de85d57d66b816848f3161b9f763ddbd84e9fafe6bc2027fb478b31b7c6f858750 SHA512 8468843131a6f09dfa65da4f638d25f3c8b806b6275a46b5bc379d7b97ebb30518a00a8dd6433ce33b78dfddcb3e1c62ceba67e9b41e39e44a677ea2fbedeade |
126 changes: 126 additions & 0 deletions
126
app-emulation/genymotion-bin/genymotion-bin-3.1.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,126 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit bash-completion-r1 desktop pax-utils | ||
|
||
MY_PN="${PN/-bin}" | ||
MY_P="${MY_PN}-${PV}" | ||
BIN_ARCHIVE="${MY_P}-linux_x64.bin" | ||
|
||
DESCRIPTION="Complete set of tools that provide a virtual environment for Android" | ||
HOMEPAGE="https://genymotion.com" | ||
SRC_URI="${BIN_ARCHIVE}" | ||
|
||
LICENSE="genymotion" | ||
SLOT="0" | ||
KEYWORDS="-* ~amd64" | ||
|
||
RDEPEND="|| ( | ||
app-emulation/virtualbox | ||
app-emulation/virtualbox-bin | ||
) | ||
|| ( | ||
dev-libs/openssl-compat:1.0.0 | ||
=dev-libs/openssl-1.0*:0 | ||
) | ||
dev-libs/hiredis:0/0.14 | ||
sys-apps/util-linux | ||
virtual/opengl | ||
" | ||
BDEPEND="dev-util/patchelf" | ||
|
||
RESTRICT="bindist fetch" | ||
S="${WORKDIR}" | ||
|
||
QA_PREBUILT=" | ||
opt/${MY_PN}/*.so* | ||
opt/${MY_PN}/imageformats/*.so | ||
opt/${MY_PN}/plugins/*.so* | ||
opt/${MY_PN}/${MY_PN} | ||
opt/${MY_PN}/genyshell | ||
opt/${MY_PN}/player | ||
opt/${MY_PN}/${MY_PN}adbtunneld | ||
opt/${MY_PN}/gmtool | ||
" | ||
|
||
pkg_nofetch() { | ||
einfo | ||
einfo "Please visit" | ||
einfo | ||
einfo " https://www.genymotion.com/download/" | ||
einfo | ||
einfo "and download " | ||
einfo | ||
einfo " ${BIN_ARCHIVE}" | ||
einfo | ||
einfo "which must be placed in DISTDIR directory." | ||
einfo | ||
} | ||
|
||
src_unpack() { | ||
cp "${DISTDIR}/${BIN_ARCHIVE}" "${WORKDIR}" || die "cp failed" | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
chmod +x ${BIN_ARCHIVE} || die "chmod failed" | ||
yes | ./${BIN_ARCHIVE} > /dev/null || die "unpack failed" | ||
|
||
# removed windows line for bashcompletion | ||
sed -i "/complete -F _gmtool gmtool.exe/d" "${MY_PN}/completion/bash/gmtool.bash" || die "sed failed" | ||
|
||
# patch to support newer hiredis version (0.14) | ||
for i in genymotion genyshell gmtool player libcom.so.1.0.0 librendering.so.1.0.0 ; do | ||
patchelf --replace-needed libhiredis.so.0.13 libhiredis.so.0.14 "${MY_PN}/${i}" || die "Unable to patch ${i} for hiredis" | ||
done | ||
} | ||
|
||
src_install() { | ||
insinto /opt/"${MY_PN}" | ||
exeinto /opt/"${MY_PN}" | ||
|
||
# Use qt bundled | ||
doins -r "${MY_PN}"/{geoservices,Qt,QtGraphicalEffects,QtLocation,QtPositioning,QtQuick,QtQuick.2} | ||
doins -r "${MY_PN}"/{icons,imageformats,platforms,plugins,sqldrivers,translations,xcbglintegrations} | ||
doins "${MY_PN}"/libQt* | ||
doins "${MY_PN}"/libqgsttools_p.so.1 | ||
doins "${MY_PN}"/qt.conf | ||
doins "${MY_PN}"/libicu* | ||
|
||
doexe "${MY_PN}"/{libcom,librendering,libswscale,libavutil}.so* | ||
# android library | ||
doexe "${MY_PN}"/{libEGL_translator,libGLES_CM_translator,libGLES_V2_translator,libOpenglRender,libemugl_logger}.so* | ||
|
||
find "${ED}/opt/${MY_PN}" -name "*.so*" -type f -exec chmod +x {} \; || die "Change .so permission failed" | ||
|
||
doexe "${MY_PN}"/{genymotion,genyshell,player,gmtool} | ||
|
||
pax-mark -m "${ED}/opt/${MY_PN}/genymotion" | ||
pax-mark -m "${ED}/opt/${MY_PN}/gmtool" | ||
|
||
dosym ../"${MY_PN}"/genyshell /opt/bin/genyshell | ||
dosym ../"${MY_PN}"/genymotion /opt/bin/genymotion | ||
dosym ../"${MY_PN}"/gmtool /opt/bin/gmtool | ||
|
||
newbashcomp "${MY_PN}/completion/bash/gmtool.bash" gmtool | ||
|
||
insinto /usr/share/zsh/site-functions | ||
doins "${MY_PN}/completion/zsh/_gmtool" | ||
|
||
sed -i -e "s:Icon.*:Icon=/opt/${MY_PN}/icons/icon.png:" \ | ||
-e "s:Exec.*:Exec=/opt/${MY_PN}/genymotion:" \ | ||
"${HOME}"/.local/share/applications/genymobile-genymotion.desktop || die "sed failed" | ||
domenu "${HOME}"/.local/share/applications/genymobile-genymotion.desktop | ||
} | ||
|
||
pkg_postinst() { | ||
elog "Genymotion needs adb to work correctly: install with android-sdk-update-manager" | ||
elog "'Android SDK Platform-tools' and 'Android SDK Tools'" | ||
elog "Your user should also be in the android group to work correctly" | ||
elog "Then in Genymotion set the android-sdk-update-manager directory: (Settings->ADB)" | ||
elog | ||
elog " /opt/android-sdk-update-manager" | ||
} |