Skip to content

Commit

Permalink
dev-ada/libgpr: No need to select gcc compiler now
Browse files Browse the repository at this point in the history
Signed-off-by: Alfredo Tupone <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.11
  • Loading branch information
atupone committed Oct 15, 2018
1 parent d88c23c commit 0c39a7c
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 11 deletions.
55 changes: 55 additions & 0 deletions dev-ada/libgpr/files/libgpr-2018-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
--- gprbuild-gpl-2016-src/gpr/src/gpr-env.adb.old 2017-11-13 22:16:53.349083426 +0100
+++ gprbuild-gpl-2016-src/gpr/src/gpr-env.adb 2017-11-13 22:17:22.692590351 +0100
@@ -1948,6 +1948,8 @@

end if;

+ Add_Directories (Self, "/usr/share/gpr");
+
if Gpr_Prj_Path.all /= "" then
Add_Directories (Self, Gpr_Prj_Path.all);
end if;
--- gprbuild-gpl-2017-src/gpr/src/gpr-names.ads.old 2017-11-19 13:09:18.947527738 +0100
+++ gprbuild-gpl-2017-src/gpr/src/gpr-names.ads 2017-11-19 13:10:08.125654595 +0100
@@ -27,6 +27,8 @@
Name_Buffer : String (1 .. 1_000_000);
Name_Len : Natural := 0;

+ Last_Id : Name_Id := Name_Id'First;
+
procedure Get_Name_String (Id : Name_Id);
procedure Get_Name_String (Id : Unit_Name_Type);
procedure Get_Name_String (Id : File_Name_Type);
--- gprbuild-gpl-2017-src/gpr/src/gpr-names.adb.old 2017-11-19 13:10:27.674316703 +0100
+++ gprbuild-gpl-2017-src/gpr/src/gpr-names.adb 2017-11-19 13:14:38.360963627 +0100
@@ -354,6 +354,8 @@

Name_Chars.Append (ASCII.NUL);

+ Last_Id := Name_Entries.Last;
+
return Name_Entries.Last;
end Name_Enter;

@@ -427,6 +429,8 @@

Name_Chars.Append (ASCII.NUL);

+ Last_Id := Name_Entries.Last;
+
return Name_Entries.Last;
end Name_Find;

--- gprbuild-gpl-2017-src/gpr/src/gpr-snames.adb.old 2017-11-19 13:12:41.592995718 +0100
+++ gprbuild-gpl-2017-src/gpr/src/gpr-snames.adb 2017-11-19 13:16:31.980979696 +0100
@@ -53,6 +53,10 @@
return;
end if;

+ if Last_Id = Name_Id'First then
+ Add_Name ("");
+ end if;
+
Add_Name ("a");
Add_Name ("b");
Add_Name ("c");
14 changes: 3 additions & 11 deletions dev-ada/libgpr/libgpr-2018.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -20,11 +20,11 @@ RDEPEND="dev-ada/xmlada[shared?,static-libs?,static-pic?]
dev-ada/xmlada[gnat_2016=,gnat_2017=,gnat_2018=]
!net-libs/grpc"
DEPEND="${RDEPEND}
dev-ada/gprbuild[gnat_2016(-)?,gnat_2017(-)?,gnat_2018(-)?]"
>=dev-ada/gprbuild-2018[gnat_2016(-)?,gnat_2017(-)?,gnat_2018(-)?]"

S="${WORKDIR}"/${MYP}-src

PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )

src_configure() {
emake prefix="${D}"usr setup
Expand All @@ -36,14 +36,6 @@ src_compile() {
-XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$1 \
gpr/gpr.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
}
if use gnat_2016; then
GCC_PV=4.9.4
elif use gnat_2017; then
GCC_PV=6.3.0
else
GCC_PV=7.3.1
fi
GCC=${CHOST}-gcc-${GCC_PV}
if use shared; then
build relocatable
fi
Expand Down

0 comments on commit 0c39a7c

Please sign in to comment.