forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
52 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST msgpack-1.0.5.tar.gz 127834 BLAKE2B 3dcf454630021e35d5c6d5ce850d7ac74a6d11d6fe7c7ed07040daa62585bd6b11dc0f68a5b4c4bf20346c25bc23017f79f2d1bad09f175008b184461d0eea5d SHA512 bc3bf27ca7a9204c5ebc009e4a03db4fb48f6c2733bef393aed16652f07ac92c9400258818743245598343c86494d39b39017ab70d7563a5844091eca11a9faa | ||
DIST msgpack-1.0.6.tar.gz 166462 BLAKE2B 19cbef99c44b6509b829462b54cea6c6bc47a30714e5f89b8f08329f2b1b46f4dea7bab4e1c32c4b9cdee44ab10d5223f3c3cc8df52c67d5f98a917dbbc3dd99 SHA512 dde756a1f3d390067a065b12c7e2c3b94aab9378d9d41e3b5338bc2e4e809b234b390618dddd6ccff13403ac03750d7c44fa567c8f87c23350e62d4d469d9707 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_EXT=1 | ||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{10..12} pypy3 ) | ||
|
||
inherit distutils-r1 pypi | ||
|
||
DESCRIPTION="MessagePack (de)serializer for Python" | ||
HOMEPAGE=" | ||
https://msgpack.org/ | ||
https://github.com/msgpack/msgpack-python/ | ||
https://pypi.org/project/msgpack/ | ||
" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos" | ||
IUSE="+native-extensions" | ||
|
||
# extension code is relying on CPython implementation details | ||
BDEPEND=" | ||
native-extensions? ( | ||
$(python_gen_cond_dep ' | ||
>=dev-python/cython-3.0.0[${PYTHON_USEDEP}] | ||
' 'python*') | ||
) | ||
" | ||
|
||
distutils_enable_tests pytest | ||
|
||
python_prepare_all() { | ||
# Remove pre-generated cython files | ||
rm msgpack/_cmsgpack.cpp || die | ||
|
||
# native-extensions are always disabled on PyPy | ||
# https://github.com/msgpack/msgpack-python/blob/main/setup.py#L76 | ||
if ! use native-extensions ; then | ||
export MSGPACK_PUREPYTHON=1 | ||
fi | ||
|
||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
rm -rf msgpack || die | ||
epytest | ||
} |