Skip to content

Commit

Permalink
dev-lang/jerryscript: drop -Werror; fix build with GCC 12
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/840263
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jun 10, 2022
1 parent 5cfa6e0 commit 0c800e1
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
33 changes: 33 additions & 0 deletions dev-lang/jerryscript/files/jerryscript-2.4.0-no-werror.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
https://bugs.gentoo.org/840263
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -167,7 +167,6 @@ endmacro()
macro(jerry_add_compile_warnings)
foreach(_warning ${ARGV})
jerry_add_compile_flags(-W${_warning})
- jerry_add_compile_flags(-Werror=${_warning})
endforeach()
endmacro()

@@ -212,7 +211,7 @@ if(USING_GCC OR USING_CLANG)
jerry_add_compile_flags(-fno-builtin)
endif()
jerry_add_compile_warnings(all extra format-nonliteral init-self conversion sign-conversion format-security missing-declarations shadow strict-prototypes undef old-style-definition)
- jerry_add_compile_flags(-Wno-stack-protector -Wno-attributes -Werror)
+ jerry_add_compile_flags(-Wno-stack-protector -Wno-attributes)
endif()

if(USING_GCC)
--- a/targets/zephyr/Makefile.zephyr
+++ b/targets/zephyr/Makefile.zephyr
@@ -55,9 +55,8 @@ EXT_CFLAGS += -ffunction-sections -fno-inline-functions
EXT_CFLAGS += $(KBUILD_CFLAGS) $(NOSTDINC_FLAGS) $(subst -I,-isystem,$(ZEPHYRINCLUDE))

EXT_CFLAGS += -Wall -Wno-format-zero-length -Wno-pointer-sign
-EXT_CFLAGS += -Werror=format -Werror=implicit-int -Wno-unused-but-set-variable
+EXT_CFLAGS += -Wformat -Wimplicit-int -Wno-unused-but-set-variable
EXT_CFLAGS += -Wno-main -Wno-strict-aliasing -Wno-old-style-declaration
-EXT_CFLAGS += -Wno-error=format=
EXT_CFLAGS += -D_XOPEN_SOURCE=700

EXT_CFLAGS += -Wno-error=conversion
1 change: 1 addition & 0 deletions dev-lang/jerryscript/jerryscript-2.4.0-r4.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,7 @@ RESTRICT+=" test"

PATCHES=(
"${FILESDIR}/jerryscript-2.4.0-python3-r4.patch"
"${FILESDIR}/jerryscript-2.4.0-no-werror.patch"
)

src_prepare() {
Expand Down

0 comments on commit 0c800e1

Please sign in to comment.