Skip to content

Commit

Permalink
media-radio/svxlink: Backport fix for newer gcc from github.
Browse files Browse the repository at this point in the history
Thanks toralf.

Closes: https://bugs.gentoo.org/639592
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
dl1jbe committed Dec 27, 2017
1 parent 1f72beb commit 0ca6aa9
Show file tree
Hide file tree
Showing 2 changed files with 16 additions and 1 deletion.
12 changes: 12 additions & 0 deletions media-radio/svxlink/files/svxlink-15.11-gcc72.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
# backported fix for newer compilers
--- src/async/audio/AsyncAudioDeviceAlsa.cpp.orig 2017-12-27 16:32:27.185098621 +0000
+++ src/async/audio/AsyncAudioDeviceAlsa.cpp 2017-12-27 16:33:33.468067578 +0000
@@ -548,7 +548,7 @@
return false;
}

- if (::abs(real_rate - sample_rate) > 100)
+ if (::abs(static_cast<int>(real_rate) - sample_rate) > 100)
{
cerr << "*** ERROR: The sample rate could not be set to "
<< sample_rate << "Hz for ALSA device \"" << dev_name << "\". "
5 changes: 4 additions & 1 deletion media-radio/svxlink/svxlink-15.11.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit cmake-utils qt4-r2 user
inherit cmake-utils eutils qt4-r2 user

CMAKE_USE_DIR="${S}/src"

Expand Down Expand Up @@ -34,6 +34,9 @@ pkg_setup() {
}

src_prepare() {
# fix compilation problem with newer gcc bug #639592
epatch "${FILESDIR}"/${P}-gcc72.patch

cmake-utils_src_prepare
# drop deprecated desktop category (bug #475730)
sed -i -e "s:Categories=Application;:Categories=:g" src/qtel/qtel.desktop || die
Expand Down

0 comments on commit 0ca6aa9

Please sign in to comment.