Skip to content

Commit

Permalink
net-libs/libetpan: Bump to version 1.6
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Sep 14, 2015
1 parent 413348c commit 0cd5d4e
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-libs/libetpan/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libetpan-1.1.tar.gz 1657767 SHA256 ce3ac567d0f07e5b2d1fdb0045042a8295ec477cd933de1a391fd48139c1f75e SHA512 fbcaf0e467d6f7541148aa60e89e1275f3cdb2b1039b8e6eaeba476e4b4411f44acfc01936eb7c4ab92cc0a574f3dcc4836e57bdf38861008bed0d015211f82b WHIRLPOOL a8c714937d797f4e8cabb59edf2b5880723e0bc6d4947ac78a3bd31f7b2e94f36c6699f7186f527b1075460f65dbb10d7c083442b6646cba1dbf2de68dd7c291
DIST libetpan-1.5.tar.gz 6139416 SHA256 42c4d858c3c1762c3e348889fbbf6cc5e5c5e654170d1df1ebb9c14aa4579736 SHA512 7b0a3adff7d7b3a7e3ea1d1a330ef6fea5ed86077a9ccf3fb5e51548d337c6c1f1fbb9ca81560b478335a9acf34e08bfef1895a05c5a69c37e3b87651c255fd5 WHIRLPOOL c408cbef9cc4e9bfec07a6e87a5afa96ea241770564c11f625776e4d692484c75ad01724c10923e38927d344616f4d396fa652d63d8cdcb2451d2a075dd0909e
DIST libetpan-1.6.tar.gz 6144117 SHA256 7962b1f9445be24d1eb72daddabaebb427074c14a50e9dad0cebdec044c71e17 SHA512 e3f19cfe231e8cadbb6cba3a765611e3aaeb260fa78e05cea1153a59015abe547c0f3a8b84c6b41cbbd17d04a4c7ab7b14d1b1b44a1a4b24ac124cb200a191a5 WHIRLPOOL b72a50513dbd55898e79b14a53088277b12ae7ac911ab0a9692d47f85dadd1b80a9ba616bd7a2beb89d9406940f4edf24cabf93aabef0cd27d6de6bef4e29a40
76 changes: 76 additions & 0 deletions net-libs/libetpan/libetpan-1.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools eutils

DESCRIPTION="A portable, efficient middleware for different kinds of mail access"
HOMEPAGE="http://libetpan.sourceforge.net/"
SRC_URI="https://github.com/dinhviethoa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="berkdb debug gnutls ipv6 liblockfile sasl ssl static-libs"

DEPEND="berkdb? ( sys-libs/db:= )
ssl? (
gnutls? ( net-libs/gnutls )
!gnutls? ( dev-libs/openssl:0= )
)
sasl? ( dev-libs/cyrus-sasl )
liblockfile? ( net-libs/liblockfile )"
RDEPEND="${DEPEND}"

pkg_setup() {
if use gnutls && ! use ssl ; then
ewarn "You have \"gnutls\" USE flag enabled but \"ssl\" USE flag disabled!"
ewarn "No ssl support will be available in ${PN}."
fi
}

src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0-nonnull.patch

sed -i \
-e "s/-O2 -g//" \
configure.ac

eautoreconf
}

src_configure() {
local sslconf

if use ssl; then
if use gnutls; then
sslconf="--with-gnutls --without-openssl"
else
sslconf="--without-gnutls --with-openssl"
fi
else
sslconf="--without-gnutls --without-openssl"
fi

# in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
# libtool recognises it as valid shell (bug #300211)
use prefix && export CONFIG_SHELL=${BASH}
# The configure script contains an error, in that it doesn't check the
# argument of --enable-{debug,optim}, hence --disable-debug results in
# --enable-debug=no, which isn't checked and debugging flags are blindly
# injected. So, avoid passing --disable-debug when we don't need it.
econf \
$(use debug && echo --enable-debug) \
$(use_enable berkdb db) \
$(use_with sasl) \
$(use_enable ipv6) \
$(use_enable liblockfile lockfile) \
$(use_enable static-libs static) \
${sslconf}
}

src_install() {
default
use static-libs || prune_libtool_files --all
}

0 comments on commit 0cd5d4e

Please sign in to comment.