Skip to content

Commit

Permalink
app-eselect/eselect-renpy: migrate from the games eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Signed-off-by: Andrew Savchenko <[email protected]>
  • Loading branch information
bircoph committed Jul 16, 2017
1 parent 74c49bf commit 0cdeed0
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
39 changes: 39 additions & 0 deletions app-eselect/eselect-renpy/eselect-renpy-0.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="Manages renpy symlink"
HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
app-eselect/eselect-lib-bin-symlink
!<games-engines/renpy-6.99.12-r2"

S=${WORKDIR}

pkg_setup() { :; }

src_prepare() {
sed \
-e "s|@BINDIR@|${EROOT}usr/bin|" \
"${FILESDIR}"/renpy.eselect-${PV} > "${WORKDIR}"/renpy.eselect || die
eapply_user
}

src_configure() { :; }

src_compile() { :; }

src_install() {
insinto /usr/share/eselect/modules
doins renpy.eselect
}

pkg_preinst() { :; }

pkg_postinst() { :; }
14 changes: 14 additions & 0 deletions app-eselect/eselect-renpy/files/renpy.eselect-0.7
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

DESCRIPTION="Manage default renpy version"
MAINTAINER="[email protected]"
VERSION="0.7"

SYMLINK_PATH="@BINDIR@/renpy"
SYMLINK_TARGETS=( renpy-6.99 )
SYMLINK_DESCRIPTION='default renpy'
SYMLINK_CRUCIAL=1

inherit bin-symlink

0 comments on commit 0cdeed0

Please sign in to comment.