Skip to content

Commit

Permalink
kde-frameworks/kdoctools: Add /usr/share/help dir to list of doc dirs
Browse files Browse the repository at this point in the history
This is fed to kio_help from kde-frameworks/kio to populate
kde-apps/khelpcenter runtime content.

Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Feb 7, 2019
1 parent 0abb51d commit 0d0adf4
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From 79f31819b95fcb0bd3d30630f769706923d41609 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <[email protected]>
Date: Mon, 28 Jan 2019 22:50:56 +0100
Subject: [PATCH] xslt.cpp: Add /usr/share/help dir to list of paths containing
documentation

---
src/xslt.cpp | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/src/xslt.cpp b/src/xslt.cpp
index 1000e33..a0fbe4c 100644
--- a/src/xslt.cpp
+++ b/src/xslt.cpp
@@ -494,5 +494,7 @@ QStringList getKDocToolsCatalogs()
QStringList KDocTools::documentationDirs()
{
/* List of paths containing documentation */
- return QStandardPaths::locateAll(QStandardPaths::GenericDataLocation, QStringLiteral("doc/HTML"), QStandardPaths::LocateDirectory);
+ QStringList docDirs = QStandardPaths::locateAll(QStandardPaths::GenericDataLocation, QStringLiteral("help"), QStandardPaths::LocateDirectory);
+ docDirs.append(QStandardPaths::locateAll(QStandardPaths::GenericDataLocation, QStringLiteral("doc/HTML"), QStandardPaths::LocateDirectory));
+ return docDirs;
}
--
2.20.1

46 changes: 46 additions & 0 deletions kde-frameworks/kdoctools/kdoctools-5.54.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_QTHELP="false"
inherit kde5

DESCRIPTION="Tools to generate documentation in various formats from DocBook files"
LICENSE="MIT"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="nls"

BDEPEND="
dev-lang/perl
dev-perl/URI
nls? ( $(add_frameworks_dep ki18n) )
"
DEPEND="
$(add_frameworks_dep karchive)
app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
app-text/sgml-common
dev-libs/libxml2:2
dev-libs/libxslt
"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${P}-gentoo-docbundledir.patch" )

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package nls KF5I18n)
)

kde5_src_configure
}

src_test() {
# bug 665622
local myctestargs=(
-E "(kdoctools_install)"
)

kde5_src_test
}

0 comments on commit 0d0adf4

Please sign in to comment.