forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.11, Repoman-2.3.3
- Loading branch information
Jeroen Roovers
committed
Oct 13, 2017
1 parent
3901be7
commit 0d1be8a
Showing
2 changed files
with
74 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST debhelper_10.8.tar.xz 418392 SHA256 15fd4ffa30657cffab6cd7a3aeff2429a64e9c80745e96ecdedc1360f1501ab2 SHA512 c867eaedcd6a31befd8bfe6b91d7aee68f0f210baacde4e709c66b86ffa8479e4f635270f9cdfff19cc9aea3c41c645679a47af4eed15308c2808df9b818ea86 WHIRLPOOL 73be55020fa026b7e90d20e1b64ee450af472b3db17a2fad6ca6063ac3c1cff98cfe4f8f33d6d94c844fe2d74588d0f1fb64132749133b7077ba64896f227dbe | ||
DIST debhelper_10.9.1.tar.xz 423464 SHA256 62d44d209b11806358a04ac977913b33d60da69f5cb48b150ab4ccbd30e9f6af SHA512 0e34c3375776c9d2eebbfee76a8677c681342055b232dc8673d8fe91f9dd62e444309dca79fa819a901558cd80452a60d9a98d9cdf5c6955f3f1adcf117d91aa WHIRLPOOL e2160007d4c4a735a52e18bb5e0f83ad516cca8f0031b8d8d332644a8fbdfb9cfc35e7ce8a9b1767f4c97d3134ac5ecadf5d60c5ab003de975b2b1ae844fcebc | ||
DIST debhelper_10.9.tar.xz 420736 SHA256 85905a4c7d36137e1d51df064c5177c76535b37fcd4b7d28c68622c877ddab41 SHA512 0efec68a6a01530e57f220593e66ff9f527aa57deb1df025728a52754e32ea6a4f5d57e9c8fb4fb2eb0c584cd9951dd69a92aeaf0c274806c17473ef9926ac61 WHIRLPOOL ce83de4eb9fe28b5f1e3d1a2ac7bddab19c8dc0c6e8852a7d9c5c01b2c4a95848cb05a15248fc8024168ed8042e1a74587821c0c6785baf2a2c1b722c6efcdaa | ||
DIST debhelper_9.20160814.tar.xz 344328 SHA256 2834a7c1dbeafd9402ea68948c815dab19d903503c45fd70e676269fccd359c0 SHA512 63072ba35ec8c62ee4c4d44833712925264c808a91f1522ef6a73377f2da3d11b285a21ad39158fd44693c801916189261186c8c7b28096719328a81a0a65f62 WHIRLPOOL 334f0aa8075896ec13a061b9841adb5f2b7c5fa6996b507785f50389c86c48e3c89a84ff1049ae7d7cbe4876b649010f892f54f1074ecafd76061bf0588e65d6 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,73 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit eutils toolchain-funcs | ||
|
||
DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules" | ||
HOMEPAGE="https://packages.qa.debian.org/d/debhelper.html" | ||
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux" | ||
IUSE="test" | ||
DH_LINGUAS=( de es fr ) | ||
IUSE+=" ${DH_LINGUAS[@]/#/linguas_}" | ||
|
||
NLS_DEPEND=$( | ||
printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]} | ||
) | ||
|
||
RDEPEND=" | ||
>=dev-lang/perl-5.10:= | ||
>=app-arch/dpkg-1.17 | ||
dev-perl/TimeDate | ||
virtual/perl-Getopt-Long | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
${NLS_DEPEND} | ||
test? ( | ||
dev-perl/Test-Pod | ||
sys-apps/fakeroot | ||
) | ||
" | ||
|
||
S=${WORKDIR}/${PN} | ||
|
||
src_compile() { | ||
tc-export CC | ||
|
||
local LANGS="" USE_NLS=no lingua | ||
for lingua in ${DH_LINGUAS[@]}; do | ||
if use linguas_${lingua}; then | ||
LANGS+=" ${lingua}" | ||
USE_NLS=yes | ||
fi | ||
done | ||
|
||
emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install | ||
dodoc doc/* debian/changelog | ||
docinto examples | ||
dodoc examples/* | ||
local lingua | ||
for manfile in *.1 *.7 ; do | ||
for lingua in ${DH_LINGUAS[@]}; do | ||
case ${manfile} in | ||
*.${lingua}.?) | ||
use linguas_${lingua} \ | ||
&& cp ${manfile} "${T}"/${manfile/.${lingua}/} \ | ||
&& doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/} | ||
;; | ||
*) | ||
doman ${manfile} | ||
;; | ||
esac | ||
done | ||
done | ||
} |