Skip to content

Commit

Permalink
app-admin/ryzen_smu: migrate to linux-mod-r1
Browse files Browse the repository at this point in the history
I don't actually use this (no hardware), but migrating myself as an
example given it's simple and cleanups the CC_IS_CLANG checks. Sorry
if it breaks anything (feel free to mask or revert if need be).

Haven't heard from slashbeast (maybe didn't notice PR), but hopefully
this is okay.

Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed May 29, 2023
1 parent fcf365b commit 0d61c12
Showing 1 changed file with 28 additions and 0 deletions.
28 changes: 28 additions & 0 deletions app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit linux-mod-r1

DESCRIPTION="Kernel driver for AMD Ryzen's System Management Unit"
HOMEPAGE="https://github.com/leogx9r/ryzen_smu"
SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

src_compile() {
local modlist=( ryzen_smu )
local modargs=( KERNEL_BUILD="${KV_OUT_DIR}" )

linux-mod-r1_src_compile
}

src_install() {
linux-mod-r1_src_install

insinto /usr/lib/modules-load.d
doins "${FILESDIR}"/ryzen_smu.conf
}

0 comments on commit 0d61c12

Please sign in to comment.