Skip to content

Commit

Permalink
dev-scheme/gauche: new upstream release
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/695924
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Akinori Hattori <[email protected]>
  • Loading branch information
hattya committed Apr 30, 2020
1 parent e458c40 commit 0db47e1
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-scheme/gauche/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST Gauche-0.9.6.tgz 6927530 BLAKE2B 9b32a0db4fc41e2b35331818850e7aa3c1ac5b1294c76caa053abe1ae2da20a0ac4424470ca94626108f996700d1b7e52f6f9e5c6f0a2326f7e6862880f48aa1 SHA512 1d8a7f56fd9ca183d6dce1dedadfaec7c7150c29540e5158f2a61977f7406d7d7a8ab753ef1912865a7d7e9a9e2fa845d86b2eb4c5e07a176f1c60276bc1908f
DIST Gauche-0.9.8.tgz 7101599 BLAKE2B 032c27b1bf5a15e7b1871801f57d9deefb4657c1921104bdb978f70df3627cf392be13dbe1a9cab4346d459c57ee4b31b622269cfc42451afdfaeb6751efc836 SHA512 53c8b022593385167a7fde7d6e8e1bfffeec91a765ffba3295c0c7a840b68977aad83d1460bdc77a5b3e0420b90eaaf55b1b7acba469f855cc6a1b72bd81f3cf
DIST Gauche-0.9.9.tgz 7244347 BLAKE2B 843fe0c7341c7020ad9130edfc41f02eeda0bc2e1f8983f83faf443f69073e132a9a2f37e6a6260334ab9aacc3e976a2df68d4c43f17f6ea07531c14e783efec SHA512 ff6fdc80bd14c4a5dc57b5a6ac9558078a557cd30c2efe98146c3817a7830ef2b3f5bb6184ce6b8ac9b1b9cb636f041643fa761b2f99e6dd0602e13e7928e210
61 changes: 61 additions & 0 deletions dev-scheme/gauche/gauche-0.9.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit autotools

MY_P="${P^g}"

DESCRIPTION="A Unix system friendly Scheme Interpreter"
HOMEPAGE="http://practical-scheme.net/gauche/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"

LICENSE="BSD"
SLOT="0/$(ver_cut 1-2)7"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="ipv6 libressl mbedtls test"
RESTRICT="!test? ( test )"

RDEPEND="sys-libs/gdbm
mbedtls? ( net-libs/mbedtls:= )"
DEPEND="${RDEPEND}
test? (
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl:0 )
)"
S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}"/${PN}-ext-ldflags.patch
"${FILESDIR}"/${PN}-gauche.m4.patch
"${FILESDIR}"/${PN}-info.patch
"${FILESDIR}"/${PN}-rfc.tls.patch
"${FILESDIR}"/${PN}-xz-info.patch
)
DOCS=( AUTHORS ChangeLog HACKING.adoc README.adoc )

src_prepare() {
default
use ipv6 && sed -i "s/ -4//" ext/tls/ssltest-mod.scm

eautoconf
}

src_configure() {
econf \
$(use_enable ipv6) \
--with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
--with-libatomic-ops=no \
--with-slib="${EPREFIX}"/usr/share/slib \
--with-tls=axtls$(usex mbedtls ',mbedtls' '')
}

src_test() {
emake -j1 -s check
}

src_install() {
emake DESTDIR="${D}" install-pkg install-doc
einstalldocs
}

0 comments on commit 0db47e1

Please sign in to comment.