Skip to content

Commit

Permalink
dev-ml/labltk: add 8.06.10
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/794964
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jun 9, 2021
1 parent d0f88b1 commit 0dc9e7b
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/labltk/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST labltk-8.06.10.tar.gz 371871 BLAKE2B da67b13aa0a0c179c2fcefe6b03f68225b6e886a1233de77b9749be32b8efc845cac60244f9a8494241c8c77c7d6991786280c274becb70f5527ad891c3aac69 SHA512 ef797d21adac48ca5ed35d95ad05fee26f9b6c99b0510909f6087abb9580b8efd219ca65b1efddb170b5409567d83eaaac0473898f5f4db3e15ae4f39df364c8
DIST labltk-8.06.7.tar.gz 370870 BLAKE2B 2d836c824d9adbd4f03d0e7e81faa51669837eecb4f94f6c89c657966774fe7d6ed928459be3ccca7fd3e7cf67a54ee63f7d2d08dcc8b7e853f5ad64769b33a2 SHA512 3c7352d14bc337adfb1939e72bd2658bb5e60b463f10f3748779084d1b7a6e6225028c775b548e355d69984a8944b91580fa978ff904b20b8b762ba9046f5e7d
DIST labltk-8.06.9.tar.gz 371504 BLAKE2B 587ff01da120501f85f6d9921e46275858f1e1ce730eef205f9e7d7c64f6d3c0ea701cf832fdb8eb0746e1f0cff1151bccb077641740fb18811473b1553e2940 SHA512 fd6defa302d919f229394c486dcefab110b144534525a87082a27d2cab29c0af4ece3da821098fea25416850ad857f7af979d48790330d62dfb8d8db8f2bf6ca
44 changes: 44 additions & 0 deletions dev-ml/labltk/labltk-8.06.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit findlib

DESCRIPTION="OCaml interface to the Tcl/Tk GUI framework"
HOMEPAGE="https://garrigue.github.io/labltk/"
SRC_URI="https://github.com/garrigue/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="QPL-1.0 LGPL-2"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+ocamlopt X"

RDEPEND="dev-lang/tk:=
>=dev-lang/ocaml-4.11:=[ocamlopt?,X(+)?]"
DEPEND="${RDEPEND}
dev-ml/findlib
"

PATCHES=(
"${FILESDIR}/findlib.patch"
)

src_configure() {
./configure --use-findlib --verbose $(usex X "--tk-x11" "--tk-no-x11") || die "configure failed!"
}

src_compile() {
emake -j1
use ocamlopt && emake -j1 opt
}

src_install() {
findlib_src_preinst
dodir /usr/bin
emake \
INSTALLDIR="${D}/$(ocamlc -where)/labltk" \
INSTALLBINDIR="${ED}/usr/bin/" \
install
dodoc Changes README.mlTk
}

0 comments on commit 0dc9e7b

Please sign in to comment.