Skip to content

Commit

Permalink
sys-apps/checkpolicy: bump to 2.6-rc1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
perfinion committed Oct 3, 2016
1 parent e4b7b4f commit 0ddc4c4
Show file tree
Hide file tree
Showing 3 changed files with 56 additions and 1 deletion.
1 change: 1 addition & 0 deletions sys-apps/checkpolicy/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST checkpolicy-2.5.tar.gz 69857 SHA256 33af9f3eb19135a7e6536ecd3fbb9686323000016cd51eb88346346ed7546001 SHA512 cbbb57fabc26951e7a61fc867720f34d8c9ccf259744e86c1fa8d5e8099d90dee7c8e69dd001c4f3224562c3e0aff36051b0d227ac102790f94a104ca90163ad WHIRLPOOL f4339877514da938c995a33558317f3d8b9110127c36e3f6c3e916ccff73c84dcc3f4e2e944c571962d1594d02cb6236ecaf616f12d1de52fca7e1b859980d72
DIST checkpolicy-2.6-rc1.tar.gz 69769 SHA256 3d76ded6a5393ec39710f66414d6a0c9c397d96a1b7b8a3c08e9a24b5c6b2143 SHA512 506aea34ceee6059f7570574a2ccd42f5e8b85eadc32043208a18e5c062bdd341e33c2dcfd7904e9438025c14cc513cc9d2c33924020cfc0311ff2b1c997068c WHIRLPOOL ce32d560a553d435c5a714004c533641e5f5bfe3421beb5e68cbdcf19dabb90fb3659b11050e6665acd97212559afe6e07e2cbd89e357ae60c0c8c0e285bc723
54 changes: 54 additions & 0 deletions sys-apps/checkpolicy/checkpolicy-2.6_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

inherit toolchain-funcs

MY_P="${P//_/-}"
MY_RELEASEDATE="20160930"

SEPOL_VER="${PV}"
SEMNG_VER="${PV}"

DESCRIPTION="SELinux policy compiler"
HOMEPAGE="http://userspace.selinuxproject.org"

if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${MY_P}/${PN}"
else
SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
S="${WORKDIR}/${MY_P}"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="debug"

DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
>=sys-libs/libsemanage-${SEMNG_VER}
sys-devel/flex
sys-devel/bison"

RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"

src_compile() {
emake CC="$(tc-getCC)" YACC="bison -y" LIBDIR="\$(PREFIX)/$(get_libdir)"
}

src_install() {
emake DESTDIR="${D}" install

if use debug; then
dobin "${S}/test/dismod"
dobin "${S}/test/dispol"
fi
}

pkg_postinst() {
einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
}
2 changes: 1 addition & 1 deletion sys-apps/checkpolicy/checkpolicy-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ EAPI="6"
inherit toolchain-funcs

MY_P="${P//_/-}"
MY_RELEASEDATE="20160223"
MY_RELEASEDATE="20160930"

SEPOL_VER="${PV}"
SEMNG_VER="${PV}"
Expand Down

0 comments on commit 0ddc4c4

Please sign in to comment.