Skip to content

Commit

Permalink
dev-python/superlance: bump to 0.14
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
sbraz authored and Michael Palimaka committed Sep 29, 2016
1 parent 50f53ac commit 0dde513
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/superlance/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST superlance-0.11.tar.gz 33882 SHA256 ab3aa27f2985c840f59f19b90e75b62e43d8d70e41b0cdc6523a884fb32f9d6e SHA512 bdf6da9e26f4db6f32f79cc27987fd75d2902ca6c098cf9c07785791fe50d3546348689391636eac25d963cd09edb2e57669e5526e68bddfd78c88eb9918fd91 WHIRLPOOL 9c85c8a68d60b195c5cb8d67a0f4e47cf5701c3b2b6711ad28ae1b11cf81723a9c0265e29f0cfed7d415d375a42abe0147101444b9fb969db598a3b786bb8140
DIST superlance-0.13.tar.gz 35009 SHA256 51fb4c990ed6dda553fbc541c5d638b614dfd8bd2832a3d958300c75dc2bf83a SHA512 283a49f345901c9212b4fa44b6cf47590c70ee9861bcedaf5c85ef74b445998e890daf9aa2d45ca32e66e8b41d9ca54eb12d860403c536265415e473dc8a2ffc WHIRLPOOL c8203367bec0f8c14c1b28607a5cd77f65a0d34a07f09bd32127fcc0dbbde280a9ff0bdfffe113c1122deb9a16225e9d9df60ad8aa616942fe042ca2e5e5749e
DIST superlance-0.14.tar.gz 36237 SHA256 74bba9be799a3eacb4120f05d2999d401365527f3cd0e924f68b6e475367c987 SHA512 41fdc9cf83ce636aea3665aed0fa9b1a37c2fe4d3740db694c20f60676d44ee6cc534ae038018edc0a1057607bac9dd4f0d14ea365735148a19a10e138723efd WHIRLPOOL b11f7eaf04f108b9183cbdb2f6ab329bd663fb8a1a1845c6e949f1e3b1fe32550ca432990203f2274fb4bc33145047f9b446d3bf181233bff6df34f32f9ae0c8
41 changes: 41 additions & 0 deletions dev-python/superlance/superlance-0.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

DESCRIPTION="A set of plugins to monitor and control supervisor"
HOMEPAGE="https://github.com/Supervisor/superlance"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="repoze"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

RDEPEND="app-admin/supervisor[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
)
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
esetup.py test
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit 0dde513

Please sign in to comment.