forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libva-intel-media-driver: add 22.6.2
Signed-off-by: Conrad Kostecki <[email protected]>
- Loading branch information
Showing
2 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
54 changes: 54 additions & 0 deletions
54
media-libs/libva-intel-media-driver/libva-intel-media-driver-22.6.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit cmake | ||
|
||
if [[ ${PV} == *9999 ]] ; then | ||
: ${EGIT_REPO_URI:="https://github.com/intel/media-driver"} | ||
if [[ ${PV%9999} != "" ]] ; then | ||
: ${EGIT_BRANCH:="release/${PV%.9999}"} | ||
fi | ||
inherit git-r3 | ||
else | ||
MY_PV="${PV%_pre}" | ||
SRC_URI="https://github.com/intel/media-driver/archive/intel-media-${MY_PV}.tar.gz" | ||
S="${WORKDIR}/media-driver-intel-media-${MY_PV}" | ||
if [[ ${PV} != *_pre* ]] ; then | ||
KEYWORDS="~amd64" | ||
fi | ||
fi | ||
|
||
DESCRIPTION="Intel Media Driver for VA-API (iHD)" | ||
HOMEPAGE="https://github.com/intel/media-driver" | ||
|
||
LICENSE="MIT BSD redistributable? ( no-source-code )" | ||
SLOT="0" | ||
IUSE="+redistributable test X" | ||
|
||
RESTRICT="!test? ( test )" | ||
|
||
DEPEND=">=media-libs/gmmlib-22.1.8:= | ||
>=media-libs/libva-2.14.0[X?] | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-21.4.2-Remove-unwanted-CFLAGS.patch | ||
"${FILESDIR}"/${PN}-20.4.5_testing_in_src_test.patch | ||
) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DMEDIA_BUILD_FATAL_WARNINGS=OFF | ||
-DMEDIA_RUN_TEST_SUITE=$(usex test) | ||
-DBUILD_TYPE=Release | ||
-DPLATFORM=linux | ||
-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X) | ||
-DENABLE_NONFREE_KERNELS=$(usex redistributable) | ||
-DLATEST_CPP_NEEDED=ON # Seems to be the best option for now | ||
) | ||
local CMAKE_BUILD_TYPE="Release" | ||
cmake_src_configure | ||
} |