Skip to content

Commit

Permalink
dev-php/pecl-apcu: bump to v5.1.19
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Oct 5, 2020
1 parent 2f7ce12 commit 0edea94
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-apcu/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST apcu-5.1.18.tgz 94668 BLAKE2B c88af867a5f0f3feb550b4b93b83451d972d8f9c2281af8b000b45cb42e2d005f82fe626da8665e0490c79bc378cf9ee5c9a0136d0b490a1155a885bb56fe4f2 SHA512 5e9c5b4540be7abdf2f473d2f8955d8708934a1d6e05cb2c99154cc7ba8a2bbf9afde51769e20f46ef278efd6f60b9172e0864c31e0976b9d3096a337035e7a9
DIST apcu-5.1.19.tgz 96583 BLAKE2B 330c08a4e557691d0b402111877b3caf56b211256db17cce52a76aeefce7237505eca4ecd71f3770ef3c405182a1604a92cc458cb9bca435b42370fe917e21a7 SHA512 45077e3bd0eac207539e2eafe21968c71f49b8c8920168dbafa87961b041f1d348b6bf1c130104744bc541e1f690854f0a29062e9520db81c04edeee3ef2ed99
67 changes: 67 additions & 0 deletions dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PHP_EXT_NAME="apcu"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS=( NOTICE README.md TECHNOTES.txt )

USE_PHP="php7-1 php7-2 php7-3 php7-4"

inherit php-ext-pecl-r3

KEYWORDS="~amd64 ~arm64 ~x86"

DESCRIPTION="Stripped down version of APC supporting only user cache"
LICENSE="PHP-3.01"
SLOT="7"

LOCKS="pthreadmutex pthreadrw spinlock semaphore"

LUSE=""
for l in ${LOCKS}; do
LUSE+="lock-${l} "
done

IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"

REQUIRED_USE="^^ ( $LUSE )"

src_prepare() {
php-ext-source-r3_src_prepare
# Remove broken tests from php 7.4 due to trivial output differences
if use php_targets_php7-4 ; then
php_init_slot_env "php7.4"
rm "${PHP_EXT_S}"/tests/apc_entry_00{2,3}.phpt || die
fi
}

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-apcu
$(use_enable mmap apcu-mmap)
$(use_enable lock-spinlock apcu-spinlocks)
)
# Broken upstream autoconf test disables if present at all
use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )

php-ext-source-r3_src_configure
}

src_install() {
php-ext-pecl-r3_src_install

insinto /usr/share/php7/apcu
doins apc.php
}

pkg_postinst() {
elog "The apc.php file shipped with this release of pecl-apcu was"
elog "installed to ${EPREFIX}/usr/share/php7/apcu/."
elog
elog "If you depend on the apc_* functions,"
elog "please install dev-php/pecl-apcu_bc as this extension no longer"
elog "provides backwards compatibility."
}

0 comments on commit 0edea94

Please sign in to comment.