forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-plasma/xembed-sni-proxy: 5.26.4 version bump
Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
2 changed files
with
43 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST plasma-workspace-5.25.5.tar.xz 18638932 BLAKE2B f83aabf84b775c0bf9d1e60db03f94400e3363fa8f45767bdc471706682cda7323fae4948cffa156188cc7ed2d30d05349a385dd370ef941c16464ddddf8fa01 SHA512 0c6cf5104b584b34a8bcb45d57069fed3b25e871fccf1bfefd47d8fc1b595867c1c4f0fcfcc0e07847534e1e77ce8ed1f3be1ac6cb7eea8669a9c7649c8466cb | ||
DIST plasma-workspace-5.26.3.tar.xz 17460024 BLAKE2B 4dd372beb55e4532d527f818a062e04e1dcd818c8f305f30fe3b8e0a1508cbfa38542a16bbd2ef5f99234a08c78fb7488b4e64d12fa320ce71175cc52bda1a48 SHA512 a5cba6b64e697cdf6bad07862aa1898bcadf7251cab019bbab3cfb6a5156cd9fdf4c79d5998e55336034f9b1295bfbb7fae17394b6f34a6a5bcdf0dae010c8fa | ||
DIST plasma-workspace-5.26.4.tar.xz 17466220 BLAKE2B bfde559460d3bafa60f4ccd2448cf710d0c8734c2e08ad7df6bce3ce728745977cef7f117041559b3269583b7bea51b66dccf12e96914369a5d4e9a1b770149b SHA512 10fa1881741e452de71472f3d4925bd9d43853d4e7acd70197e796d9e01907fe91411e11b954b4bfc10560079b887ce53cbe200ea967987d1c0c813e9f78b3d1 |
42 changes: 42 additions & 0 deletions
42
kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.26.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
KDE_ORG_NAME="plasma-workspace" | ||
KFMIN=5.99.0 | ||
PVCUT=$(ver_cut 1-3) | ||
QTMIN=5.15.5 | ||
inherit cmake plasma.kde.org | ||
|
||
DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays" | ||
HOMEPAGE="https://invent.kde.org/plasma/plasma-workspace/-/blob/master/xembed-sni-proxy/Readme.md" | ||
CMAKE_USE_DIR="${S}/${PN}" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="5" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv" | ||
|
||
DEPEND=" | ||
>=dev-qt/qtcore-${QTMIN}:5 | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtx11extras-${QTMIN}:5 | ||
>=kde-frameworks/kwindowsystem-${KFMIN}:5[X] | ||
x11-libs/libxcb | ||
x11-libs/libXtst | ||
x11-libs/xcb-util-image | ||
" | ||
RDEPEND="${DEPEND} | ||
!kde-plasma/xembed-sni-proxy:0 | ||
" | ||
BDEPEND=">=kde-frameworks/extra-cmake-modules-${KFMIN}:5" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-5.24.80-standalone.patch" ) | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
|
||
sed -e "/set/s/GENTOO_PV/$(ver_cut 1-3)/" \ | ||
-i ${PN}/CMakeLists.txt || die "Failed to prepare CMakeLists.txt" | ||
} |