forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.20.1
- Loading branch information
Showing
2 changed files
with
77 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST libpwquality-1.2.3.tar.bz2 367794 SHA256 b11c79ce7b03cdf878fccb653e67bd430155cc6fd224efbbb3e78842f752516a SHA512 1591f40feee4ad95d666887fbd04fc675ff2630a2cd080a7ef616f59af543751ef34910a085d880e8d75051ebeee747847b8015e66a7c315b955df62f926ccd2 WHIRLPOOL 9aff4c547758a2bc2d918f2411371f3b35231c6846d77b497275176842f8f48df3b66f419ddaee88e1fccc2e1a6b947e5b1e72215db74dbc978089d7c0afdf5b | ||
DIST libpwquality-1.2.4.tar.bz2 394060 SHA256 9ad67be364a66dc8b334a473c77d9f531137ee0e9d85d81f567f410a375857c7 SHA512 63ead296320e8eadc1a3341c28b015f9dbbf30e610e9226a11018d81aeb412d0e211753ebdb45f959c35cedfc6ed580bba9e6b0f8822c3b5f38062428f637049 WHIRLPOOL 94166db5bba425fb19a9a27fe27eb082716e887b90fa2d2bd64e56f4d9202c6cc1f7f16779185a5c44ce3145f8a8df92ecca9b6628ae63daba99aca4d5a9c1a9 | ||
DIST libpwquality-1.3.0.tar.bz2 423910 SHA256 74d2ea90e103323c1f2d6a6cc9617cdae6877573eddb31aaf31a40f354cc2d2a SHA512 c3817c7a5ca962b161911b97b413a0db7c34a99ba2cd191435024abdbe060e248c0f88436f24d3992dcb1b00d34b88afb731ef1fd23efc3ad1abe56d4d7d53ea WHIRLPOOL b6451083551a13be259d1a81eb089889d9ee430c30afb2555aa2e5e7c4240febc71b152ce3c210b592a56db8988fc88a827d8e9f368c5aa478d5babf4e316b8c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,76 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
PYTHON_COMPAT=( python{2_7,3_3,3_4} ) | ||
|
||
inherit eutils multilib pam python-r1 toolchain-funcs | ||
|
||
DESCRIPTION="Library for password quality checking and generating random passwords" | ||
HOMEPAGE="https://fedorahosted.org/libpwquality/" | ||
SRC_URI="https://fedorahosted.org/releases/l/i/${PN}/${P}.tar.bz2" | ||
|
||
LICENSE="|| ( BSD GPL-2 )" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86" | ||
IUSE="pam python static-libs" | ||
|
||
RDEPEND=" | ||
>=sys-libs/cracklib-2.8:= | ||
pam? ( virtual/pam ) | ||
python? ( ${PYTHON_DEPS} ) | ||
" | ||
DEPEND="${RDEPEND} | ||
>=sys-devel/gettext-0.18.2 | ||
virtual/pkgconfig | ||
" | ||
|
||
src_prepare() { | ||
# ensure pkgconfig files go in /usr | ||
sed -e 's:\(pkgconfigdir *=\).*:\1 '${EPREFIX}/usr/$(get_libdir)'/pkgconfig:' \ | ||
-i src/Makefile.{am,in} || die "sed failed" | ||
use python && python_copy_sources | ||
} | ||
|
||
src_configure() { | ||
# Install library in /lib for pam | ||
configuring() { | ||
local sitedir | ||
econf \ | ||
--libdir="${EPREFIX}/$(get_libdir)" \ | ||
$(use_enable pam) \ | ||
--with-securedir="${EPREFIX}/$(getpam_mod_dir)" \ | ||
$(use_enable python python-bindings) \ | ||
$(usex python "--with-pythonsitedir=$(use python && python_get_sitedir)" "") \ | ||
$(use_enable static-libs static) | ||
} | ||
if_use_python_python_foreach_impl configuring | ||
} | ||
|
||
src_compile() { | ||
if_use_python_python_foreach_impl default | ||
} | ||
|
||
src_test() { | ||
if_use_python_python_foreach_impl default | ||
} | ||
|
||
src_install() { | ||
if_use_python_python_foreach_impl default | ||
if use static-libs; then | ||
# Do not install static libs in /lib | ||
mkdir -p "${ED}usr/$(get_libdir)" | ||
mv "${ED}$(get_libdir)/libpwquality.a" "${ED}/usr/$(get_libdir)/" || die | ||
gen_usr_ldscript libpwquality.so | ||
fi | ||
prune_libtool_files --modules | ||
} | ||
|
||
if_use_python_python_foreach_impl() { | ||
if use python; then | ||
python_foreach_impl run_in_build_dir "$@" | ||
else | ||
"$@" | ||
fi | ||
} |