Skip to content

Commit

Permalink
sys-fs/aufs4: Bump to latest aufs release
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Feb 12, 2016
1 parent 057ba34 commit 0efe26f
Show file tree
Hide file tree
Showing 2 changed files with 165 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/aufs4/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -14,3 +14,4 @@ DIST aufs4-standalone-0_pre20151116.tar.xz 741280 SHA256 362d56dac519b35e73cb93b
DIST aufs4-standalone-0_pre20151221.tar.xz 782884 SHA256 7871f3159418956ab7498df800cf082c55ea84af82720c2fe254cfe0ddbb090f SHA512 a0f5e0af490209b3ac76bcb8c2ac31dcff05d881b9dad314c701ac84b990c26b0b5beb59f36ce5e373b6548052eeda1389bd8ba39a5be15b9eeea13dfc9b2c65 WHIRLPOOL 92cf2595e167a47f571d565a61e69dee779b8a7dc52400492eb52bf9107936787d570f48af517d935fedb8ef89cfafcdde0b8c0bae2968dd3e69a80b58e42f5d
DIST aufs4-standalone-0_pre20160111.tar.xz 804572 SHA256 0ecba8c2f34443d316a3d8e49f4678005ec82cd5052afde4937020b6f5641853 SHA512 e42e0374b7325ae1d1c2d99c9bac726953431e91607352219d2861a0aae32fd016c7a2e1321f2410f26e2b61cbfadc748242f74e74d309e2024d899f2d48448b WHIRLPOOL e381244e327939a78ecc6ad4314090ebd1c790422db31bc9e70501d120df5ecfa9dd4235ff17b007a08e958218975226b61490fa1caacb6aa317a6aa705dc67b
DIST aufs4-standalone-0_pre20160118.tar.xz 825208 SHA256 6c964c812470f9b85e3fc801e58a6dfb5b25ef6efbcb959b02000534a980ab74 SHA512 10b39a84aee7bec7e701576e73c8107381dd06ae200754cc7cc48a84cd806a7819659390b750459c50271886ed9055071acbdaaa5a0d3a72be53313180a3c85e WHIRLPOOL c6bf2a0fceaae478ef6da747df9e8abf0b2c6a4c76c0d9feb0a8670bbf6adec3c6422cfbe3c8997b0bfacb2da10e803c038138365d647c0da24fd9aeea8d5c42
DIST aufs4-standalone-0_pre20160215.tar.xz 931276 SHA256 2303db1f8116762baf0aeadb8191c0bf9ed00380a5855b2297c92716a50fc2aa SHA512 e07dee042700edb6c4aafc995910181b59067e5a62d8bdcbb8992efdd1f5afcb0d38322e85a0efe57dfee465c0e74bb597928fb3bbf5db86c4d2007a9fd88c46 WHIRLPOOL ef611cbf47204b9691bd432a83898e5543754dcdf5597a18fb0327f3b269f3c7cfcfc2e0a46bc0ec0952eee114508d81decfa59c03a683a74292d123c24bea3d
164 changes: 164 additions & 0 deletions sys-fs/aufs4/aufs4-0_pre20160215.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,164 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo toolchain-funcs

AUFS_VERSION="${PV%%_p*}"
# highest branch version
PATCH_MAX_VER=3
# highest supported version
KERN_MAX_VER=4
# lowest supported version
KERN_MIN_VER=0

DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net/"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs4-standalone-${PV}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"

DEPEND="
dev-util/patchutils
dev-vcs/git"
RDEPEND="
sys-fs/aufs-util
!sys-fs/aufs
!sys-fs/aufs2
!sys-fs/aufs3"

S="${WORKDIR}"/${PN}-standalone

MODULE_NAMES="aufs(misc:${S})"

pkg_setup() {
CONFIG_CHECK+=" !AUFS_FS"
use inotify && CONFIG_CHECK+=" ~FSNOTIFY"
use nfs && CONFIG_CHECK+=" EXPORTFS"
use fuse && CONFIG_CHECK+=" ~FUSE_FS"
use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
use pax_kernel && CONFIG_CHECK+=" PAX" && ERROR_PAX="Please use hardened sources"

# this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
[ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return

get_version
kernel_is lt 4 ${KERN_MIN_VER} 0 && die "the kernel version isn't supported by upstream anymore. Please upgrade."
kernel_is gt 4 ${KERN_MAX_VER} 99 && die "kernel too new"

linux-mod_pkg_setup

if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
PATCH_BRANCH="x-rcN"
else
PATCH_BRANCH="${KV_MINOR}"
fi

case ${KV_EXTRA} in
"")
elog "It seems you are using vanilla-sources with aufs4"
elog "Please use sys-kernel/aufs-sources with USE=vanilla"
elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
;;
"-gentoo")
elog "It seems you are using gentoo-sources with aufs4"
elog "Please use sys-kernel/aufs-sources"
elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
;;
esac

pushd "${T}" &> /dev/null
unpack ${A}
cd ${PN}-standalone || die
local module_branch=origin/${PN}.${PATCH_BRANCH}
einfo "Using ${module_branch} as patch source"
git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
combinediff ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
combinediff "${T}"/combined-1.patch ${PN}-mmap.patch > ${PN}-standalone-base-mmap-combined.patch
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
if use kernel-patch; then
cd ${KV_DIR}
ewarn "Patching your kernel..."
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch >/dev/null
epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
ewarn "You need to compile your kernel with the applied patch"
ewarn "to be able to load and use the aufs kernel module"
else
eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
eerror "Either enable the kernel-patch useflag to do it with this ebuild"
eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand"
die "missing kernel patch, please apply it first"
fi
fi
popd &> /dev/null
export PKG_SETUP_HAS_BEEN_RAN=1
}

set_config() {
for option in $*; do
grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
done
}

src_prepare() {
local module_branch=origin/${PN}.${PATCH_BRANCH}

einfo "Using for module creation branch ${module_branch}"
git checkout -q -b local-gentoo ${module_branch} || die

# All config options to off
sed "s:= y:=:g" -i config.mk || die

set_config RDU BRANCH_MAX_127 SBILIST

use debug && set_config DEBUG
use fuse && set_config BR_FUSE POLL
use hfs && set_config BR_HFSPLUS
use inotify && set_config HNOTIFY HFSNOTIFY
use nfs && set_config EXPORT
use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
use ramfs && set_config BR_RAMFS

if use pax_kernel; then
epatch "${FILESDIR}"/pax-4.patch
fi

sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
}

src_compile() {
local ARCH=x86

emake \
CC=$(tc-getCC) \
LD=$(tc-getLD) \
LDFLAGS="$(raw-ldflags)" \
ARCH=$(tc-arch-kernel) \
CONFIG_AUFS_FS=m \
KDIR="${KV_OUT_DIR}"
}

src_install() {
linux-mod_src_install

insinto /usr/share/doc/${PF}

use doc && doins -r Documentation

use kernel-patch || doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch

dodoc Documentation/filesystems/aufs/README "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch

readme.gentoo_create_doc
}

pkg_postinst() {
readme.gentoo_pkg_postinst
linux-mod_pkg_postinst
}

0 comments on commit 0efe26f

Please sign in to comment.