Skip to content

Commit

Permalink
app-pda/libplist: Override PYTHON_LDFLAGS in src_configure
Browse files Browse the repository at this point in the history
Works around broken build system.

Bug: https://bugs.gentoo.org/567370

Package-Manager: portage-2.2.27_p49
  • Loading branch information
floppym committed Jan 25, 2016
1 parent 7ea81ab commit 0f0051b
Show file tree
Hide file tree
Showing 2 changed files with 12 additions and 14 deletions.
13 changes: 6 additions & 7 deletions app-pda/libplist/libplist-1.11-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -29,11 +29,6 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto

BUILD_DIR="${S}_build"

src_prepare() {
sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
eautoreconf
}

src_configure() {
local ECONF_SOURCE=${S}
local myeconfargs=( $(use_enable static-libs static) )
Expand All @@ -45,8 +40,12 @@ src_configure() {
popd >/dev/null || die
}

do_configure_python() {
PYTHON_LDFLAGS="$(python_get_LIBS)" do_configure "$@"
}

do_configure --without-cython
use python && python_foreach_impl do_configure
use python && python_foreach_impl do_configure_python
}

src_compile() {
Expand Down
13 changes: 6 additions & 7 deletions app-pda/libplist/libplist-1.12.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -29,11 +29,6 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto

BUILD_DIR="${S}_build"

src_prepare() {
sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
eautoreconf
}

src_configure() {
local ECONF_SOURCE=${S}
local myeconfargs=( $(use_enable static-libs static) )
Expand All @@ -45,8 +40,12 @@ src_configure() {
popd >/dev/null || die
}

do_configure_python() {
PYTHON_LDFLAGS="$(python_get_LIBS)" do_configure "$@"
}

do_configure --without-cython
use python && python_foreach_impl do_configure
use python && python_foreach_impl do_configure_python
}

src_compile() {
Expand Down

0 comments on commit 0f0051b

Please sign in to comment.