Skip to content

Commit

Permalink
dev-python/prov: new ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
TheChymera authored and gktrk committed Apr 9, 2017
1 parent 4e55823 commit 0f2155f
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/prov/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST prov-1.5.0.tar.gz 125045 SHA256 96a74efa1b3324961ff66246539ed7bdc06245dcbeef538688c755a0ad5777ee SHA512 d08b924385f587814f6094679649e746bc687e136ddebe1194c5d97921a081b960a5531f13cb8f83d167dbd1cf7114d2e55478431feaf52e547db24a181a2ad2 WHIRLPOOL 1e10dd7066c6b0ce09b5d46330ccdb245c1344dcc650a84d09f5fbca081ed5cb1f328058a250d27b92112929771d90c5ffa5ecd0174942dc7fa04298a0d593b8
21 changes: 21 additions & 0 deletions dev-python/prov/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Horea Christian</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
A library for W3C Provenance Data Model supporting PROV-O
(RDF), PROV-XML, PROV-JSON import/export Interface to
Graphviz’s Dot language.
</longdescription>
<upstream>
<remote-id type="pypi">prov</remote-id>
</upstream>
</pkgmetadata>

40 changes: 40 additions & 0 deletions dev-python/prov/prov-1.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit distutils-r1

DESCRIPTION="W3C provenance data dodel library"
HOMEPAGE="https://pypi.python.org/pypi/prov"
SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="
dev-python/pydotplus[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
>=dev-python/networkx-1.10[${PYTHON_USEDEP}]
dev-python/rdflib[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
"
DEPEND="
test? ( ${RDEPEND} )
dev-python/setuptools[${PYTHON_USEDEP}]
"

#the test phase fails due to a bug that may be better fixed
#in setuptools or the yajl package:
#https://github.com/gentoo/gentoo/pull/4346#issuecomment-291776642
RESTRICT="test"

python_test() {
${EPYTHON} -m unittest discover || die
}

0 comments on commit 0f2155f

Please sign in to comment.