Skip to content

Commit

Permalink
dev-haskell/wavy: WAV file processor, a depend of app-forensics/quick…
Browse files Browse the repository at this point in the history
…fuzz

Package-Manager: portage-2.3.0
  • Loading branch information
Sergei Trofimovich committed Sep 11, 2016
1 parent 95033a4 commit 0f2c647
Show file tree
Hide file tree
Showing 4 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-haskell/wavy/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST wavy-0.1.0.0.tar.gz 25100 SHA256 3849bf156ba6b2cb7f8665b66a398a175b3579534c7bc1e0f5357e7a5ad57f67 SHA512 25103aeae5104f6525b75cae4aea1b70e3998a56e4c262462a8dd7b8edfee2749fbd099e81a2c2bde0bfb0211e2194d0e4df705bd8882e526516c85be0fdd94d WHIRLPOOL 7105e0da09c621d20fc124ae32242e9c8eb0100e25c7ad0d4e8d0b78d0b5ad0cc102c392a49b9a287bc380065b1aad165a32612f2ecf5a898a30593f4f826002
14 changes: 14 additions & 0 deletions dev-haskell/wavy/files/wavy-0.1.0.0-binary-0.8.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
diff --git a/Sound/Wav/Binary.hs b/Sound/Wav/Binary.hs
index d2c539c..11883a3 100644
--- a/Sound/Wav/Binary.hs
+++ b/Sound/Wav/Binary.hs
@@ -1 +1,2 @@
+{-# LANGUAGE CPP #-}
-- | This module provides helper binary functions to get integer values from binary streams and put
@@ -8,2 +9,3 @@ import Data.Int

+#if ! MIN_VERSION_binary(0,8,0)
getInt8 :: Get Int8
@@ -31 +33,2 @@ putInt64le :: Int64 -> Put
putInt64le = putWord64le . fromIntegral
+#endif
13 changes: 13 additions & 0 deletions dev-haskell/wavy/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Haskell</name>
</maintainer>
<longdescription>
Wavy was designed to be a fast and efficient method of extracting and writing PCM
data to and from WAV files. It is here to help you make fast use of Audio
data in your Haskell programs and thus encourage many more audio projects in Haskell.
</longdescription>
</pkgmetadata>
41 changes: 41 additions & 0 deletions dev-haskell/wavy/wavy-0.1.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

# ebuild generated by hackport 0.5.9999

CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal

DESCRIPTION="Process WAVE files in Haskell"
HOMEPAGE="http://bitbucket.org/robertmassaioli/wavy"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="dev-haskell/pretty-show:=[profile?]
>=dev-haskell/riff-0.3:=[profile?] <dev-haskell/riff-0.4:=[profile?]
>=dev-haskell/split-0.2:=[profile?] <dev-haskell/split-0.3:=[profile?]
>=dev-haskell/vector-0.10:=[profile?]
>=dev-lang/ghc-7.8.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
"

PATCHES=("${FILESDIR}"/${P}-binary-0.8.patch)

src_prepare() {
default

cabal_chdeps \
'vector ==0.10.*' 'vector >= 0.10' \
'filepath ==1.3.*' 'filepath >= 1.3' \
'binary ==0.7.*' 'binary >= 0.7' \
'containers ==0.4.*' 'containers >= 0.4'
}

0 comments on commit 0f2c647

Please sign in to comment.