forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-dotnet/csharp-gentoodotnetinfo: bump to 1.1.1
Signed-off-by: Maciej Barć <[email protected]>
- Loading branch information
Showing
2 changed files
with
53 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,4 @@ | ||
DIST csharp-gentoodotnetinfo-1.0.0.tar.bz2 11273 BLAKE2B dc813e3af220b8a348716e3fd95640cd284083a463b007e5943b0f335161d3491637e47f894f276dd45b8dae74b2d057874425beef1bf3463b50eee9e480b495 SHA512 3900dd435cc122e2c368c4040413f64f5f232cb374d672f843b73c41a9a1aef2903db53f5688c223f478a521908001c025d74fbf1d59bb7608be26cf780eaf38 | ||
DIST csharp-gentoodotnetinfo-1.1.1.tar.bz2 19051 BLAKE2B e55042c43c956d7a7cef999f92ce131aaeccc10db6a248d154aabd01f9072d71baed29f1ccfdd8c3f96d094f3eab491e4a9e04e1239ae23ba22695363cd35e6a SHA512 372a61251a3a8f0df2cf2b5dc83fc6348b7551c3101646ad10086cd324363e63589d056d7f260058c5ab2f01ba759d231b078c923a592f7d11a7b81b6004fcd1 | ||
DIST microsoft.dotnet.platformabstractions.3.1.6.nupkg 72146 BLAKE2B 08d852b5e6558b499f2d780284aa747e5cf39886d86fa378128fae9f71741bd57c5bc75c0077948f193b7e8ea03a520d8ef3bd3b4fc80779adb4a84a4b44fe8c SHA512 55b87f544874686bed96889953b7e99e43426b79b0fac31cc452e0f4a27ca5cc08522c0ac967bf9df649f7c04137a5e2553d134ad79d5c1e69578367c2b4b4c6 | ||
DIST system.commandline.2.0.0-beta4.22272.1.nupkg 616636 BLAKE2B 5252560598c4cd67348520cea086c37b4151b984a61238de1984838975340247b16050113422b1765931bdfc1dee38e226789b6427e56ab7c3a36bf07d0bcc20 SHA512 979a7e66ba29e17bc5bec42e926ed15362e23ae403e498c955e09dffc4d3baa14777a06f95e25d591fc9757a0eaa18deb9e4662a1ca1663fa300f509a4a0383c |
51 changes: 51 additions & 0 deletions
51
dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.1.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DOTNET_PKG_COMPAT=7.0 | ||
NUGETS=" | ||
[email protected] | ||
[email protected] | ||
" | ||
|
||
inherit dotnet-pkg | ||
|
||
DESCRIPTION=".NET information tool for Gentoo" | ||
HOMEPAGE="https://gitlab.gentoo.org/dotnet/csharp-gentoodotnetinfo/" | ||
|
||
if [[ "${PV}" == *9999* ]] ; then | ||
inherit git-r3 | ||
|
||
EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git" | ||
else | ||
SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2" | ||
|
||
KEYWORDS="~amd64 ~arm ~arm64" | ||
fi | ||
|
||
SRC_URI+=" ${NUGET_URIS} " | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
|
||
DOTNET_PKG_PROJECTS=( | ||
Source/v1/gentoo-dotnet-info-app/GentooDotnetInfo/GentooDotnetInfo.csproj | ||
) | ||
|
||
src_unpack() { | ||
dotnet-pkg_src_unpack | ||
|
||
if [[ -n ${EGIT_REPO_URI} ]] ; then | ||
git-r3_src_unpack | ||
fi | ||
} | ||
|
||
src_install() { | ||
local launcher_dll="/usr/share/${P}/GentooDotnetInfo.dll" | ||
|
||
dotnet-pkg-base_install | ||
dotnet-pkg-base_dolauncher_portable "${launcher_dll}" gentoo-dotnet-info | ||
|
||
einstalldocs | ||
} |