Skip to content

Commit

Permalink
net-libs/libmicrohttpd: version bump to 0.9.53
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
blueness committed Apr 14, 2017
1 parent 41815b5 commit 0f39cd3
Show file tree
Hide file tree
Showing 3 changed files with 84 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-libs/libmicrohttpd/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST libmicrohttpd-0.9.47.tar.gz 1075636 SHA256 96bdab4352a09fd3952a346bc0189853
DIST libmicrohttpd-0.9.49.tar.gz 1087716 SHA256 9407d8252548ab97ace3276e0032f073820073c0599d43baff832902a8dab11c SHA512 9bae8d187e9567ef706a6d1b806417f2b5f667195adf7a86f96f156982e4cbcf472da10b3220c0679aeceb2c74e7778153160f3b697ac7444de038505b6e94f8 WHIRLPOOL 837c8612eb227c266ed3af773912bdbc215cbadc29766c5de10bce4a0588301213ea6ea140d3c15e6ec96c3dc3bc6b50caee892f30350d1c5e05b83639a61223
DIST libmicrohttpd-0.9.51.tar.gz 1114110 SHA256 3000bb0ba219061f2ea60251b8ea3d5f694e8c6ce1706bbff57e7e24867a23c7 SHA512 462178033d5fabc53885189a7f73a343a1a0d2f54e8ff6310a3e74ace3316567927c453773e62ff35150ec36658605d6d0a9c1c38c5d3186d543ca313f4a5912 WHIRLPOOL 9c68282e4f423f251e950f0016d3394c7ce97c85e86a57525a31f832fd2b6b32790a0395a0a0701ad0f4104ff575488ffaed547684d7c3f6f809a3e92bde464d
DIST libmicrohttpd-0.9.52.tar.gz 1244489 SHA256 54797f6e763d417627f89f60e4ae0a431dab0523f92f83def23ea02d0defafea SHA512 2cb7fa6ed59ec5f48748cd2aedea8a68629f02ffcf8e86c6d5b57a6622bb5f0ffd7dabfd6c04cc99047ca81eb76efe2a79b34bd6e3de329261a319369232fcf4 WHIRLPOOL b70f91dba5e6e69fe42066345d51bb72248b1c4271fa88c0599d78adf17b3eb79144e5a83159f1636a79a6c9081ebb6274d90fa307d4f78a3edbfc7e0d6bd10a
DIST libmicrohttpd-0.9.53.tar.gz 1301214 SHA256 9b15ec2d381f44936323adfd4f989fa35add517cccbbfa581896b02a393c2cc4 SHA512 2e29595c980cdcf12c1cead62f8938cc32e8c93d3a848e7473c5d5f596c6b6858732df0a3293b93d89577e5a325a62fe82adf3921a76d7184a647489364d7e2c WHIRLPOOL 940eb42aaca8581ab7c7f2f3f6c246bf001956965d5529491d780f377eb00cffbf28aec3069b6a8eb691a78d84e77555ec5554b10ce066a11333d6cae19641a4
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
commit 01df8861c19a203cea9ef26570893c2b9c0e48b2
Author: Evgeny Grin (Karlson2k) <[email protected]>
Date: Wed Apr 12 21:11:28 2017 +0300

Fixed GNU/Linux builds without epoll

diff --git a/src/microhttpd/daemon.c b/src/microhttpd/daemon.c
index 49a1b82..02713e3 100644
--- a/src/microhttpd/daemon.c
+++ b/src/microhttpd/daemon.c
@@ -2251,8 +2251,10 @@ send_param_adapter (struct MHD_Connection *connection,
if (0 < ret)
{
/* write successful */
+#ifdef EPOLL_SUPPORT
if (left > (uint64_t)ret)
connection->epoll_state &= ~MHD_EPOLL_STATE_WRITE_READY;
+#endif /* EPOLL_SUPPORT */
return ret;
}
err = MHD_socket_get_error_();
62 changes: 62 additions & 0 deletions net-libs/libmicrohttpd/libmicrohttpd-0.9.53.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

MY_P="${P/_/}"

DESCRIPTION="Small C library to run an HTTP server as part of another application"
HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0/12"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="epoll messages ssl static-libs test"

RDEPEND="ssl? (
dev-libs/libgcrypt:0=
net-libs/gnutls
)"

# We disable tests below because they're broken,
# but if enabled, we'll need this.
DEPEND="${RDEPEND}
test? (
ssl? ( net-misc/curl[ssl] )
)"

S=${WORKDIR}/${MY_P}

DOCS="AUTHORS NEWS README ChangeLog"

src_prepare() {
eapply "${FILESDIR}"/${P}-fix-build-without-epoll.patch
eapply_user
}

src_configure() {
econf \
--enable-bauth \
--enable-dauth \
--disable-examples \
--enable-postprocessor \
--disable-thread-names \
$(use_enable epoll) \
$(use_enable test curl) \
$(use_enable messages) \
$(use_enable ssl https) \
$(use_with ssl gnutls) \
$(use_enable static-libs static)
}

# tests are broken in the portage environment.
src_test() {
:
}

src_install() {
default

use static-libs || find "${ED}" -name '*.la' -delete
}

0 comments on commit 0f39cd3

Please sign in to comment.