Skip to content

Commit

Permalink
app-admin/ide-smart: Port to EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
SoapGentoo committed Dec 29, 2017
1 parent 228ff0d commit 0f3fe7c
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 5 deletions.
17 changes: 17 additions & 0 deletions app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
--- a/Makefile
+++ b/Makefile
@@ -2,13 +2,10 @@

#CC = gcc
PROF = -g0 -O2
-CFLAGS = $(PROF) -Wall
-LDFLAGS = $(PROF)
+CFLAGS += -Wall
TARGET = ide-smart
OBJECTS = ide-smart.o

-ide-smart: $(OBJECTS)
- $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS)

all: ide-smart

22 changes: 17 additions & 5 deletions app-admin/ide-smart/ide-smart-1.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,6 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

DESCRIPTION="A tool to read SMART information from harddiscs"
Expand All @@ -12,12 +14,22 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""

src_compile() {
$(tc-getCC) ${CFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c || die "compile"
PATCHES=( "${FILESDIR}"/${PN}-1.4-fix-build-system.patch )

src_prepare() {
default

# yes, the tarball includes pre-compiled
# object files and binaries
rm ${PN}{,.o} || die
}

src_configure() {
tc-export CC
}

src_install() {
dobin ide-smart || die
dobin ide-smart
doman ide-smart.8
dodoc README
einstalldocs
}

0 comments on commit 0f3fe7c

Please sign in to comment.