Skip to content

Commit

Permalink
app-admin/graylog2: Version bump to 2.4.5
Browse files Browse the repository at this point in the history
As requested by Marko Weber Bürgermeister & Leho Kraav.

Closes: https://bugs.gentoo.org/639928
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
tonyvroon committed Jun 8, 2018
1 parent dab3ccf commit 0f56edc
Show file tree
Hide file tree
Showing 2 changed files with 85 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/graylog2/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST graylog-2.1.2.tgz 94284738 BLAKE2B d4971bb6fb073f575d20204b49e7edf24773f42e4c9b84f0e1d2a5834bf8d95120ef1fa6391b22714923fa1f62e623f02a6788c82b1f48fc86f4953d484de36f SHA512 df636143ff90b0aedcb6db78e20125c10da2428b6e474e925d6fc011fdc3a0b88414ec914981a71a0e08c4916cb5cd18a8eeda28e01d9edf3b3ae4a8fb0a90dc
DIST graylog-2.2.2.tgz 99956086 BLAKE2B 55499d11d9f9a81df8670521f62a45323941f7acac1b87a4df96dfbe0f14a63640cd536ab1c8affa69fe1c774d37b75ca8d0d4bc6194622267a6f5640cf05cc7 SHA512 341548b5d48e3a2008a1264128a604320b566b8f0e8da4d2fca54a69e1412a69839d09698e13d97dd399652611a3e24dd54dc81f56bc4ca00278afbd61ba9c2c
DIST graylog-2.2.3.tgz 99971278 BLAKE2B 981568151fa22b3b180a451075c9c66c1e9148d737e4683fdbeb505fccb54729619fce554ee3efd423f971081005e73e481f69d9b81676e80f1276b4a982cd6e SHA512 19ad14bdee733b4ceed526af7f446fc74a4ac5bc6a0b4784618edd84a84aa00378c203d4051a3232c17caaf47f3ffe684cb8b17ce88c8d98e7b29bc22c0058e8
DIST graylog-2.4.5.tgz 122974260 BLAKE2B 0f04713fcee112f1018a78bea7c39b456ae167ec46c29b1b3c60326563d405a92a4d4d341860b0341a3ce2c7ad105a8ebf5068cae5b29b312d01a4fd036f277f SHA512 bfcf879ab01142894ada2639f9d191aef640fa17e7c0a5935347291e99109fa677ae9caacada6cd3b94295a290eb710c20710621376c04222d6012492331b9af
84 changes: 84 additions & 0 deletions app-admin/graylog2/graylog2-2.4.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit user

DESCRIPTION="Free and open source log management"
HOMEPAGE="https://graylog.org"
SRC_URI="https://packages.graylog2.org/releases/graylog/graylog-${PV}.tgz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"

MY_PN="graylog"
S="${WORKDIR}/${MY_PN}-${PV}"

INSTALL_DIR="/usr/share/graylog2"
DATA_DIR="/var/lib/graylog2"

QA_PREBUILT="${INSTALL_DIR}/lib/sigar/libsigar*"
RESTRICT="strip"

RDEPEND="virtual/jdk:1.8"

pkg_setup() {
enewgroup graylog
enewuser graylog -1 -1 -1 graylog
}

src_prepare() {
default

# graylogctl is replaced by our own initd
rm -r bin || die

# Stick to architecture of build host
if ! use amd64; then
rm -r lib/sigar/libsigar-amd64-*.so || die "Failed in removing AMD64 support libraries"
fi
if ! use ppc64; then
rm -r lib/sigar/libsigar-ppc64-*.so || die "Failed in removing PPC64 support libraries"
fi
if ! use x86; then
rm -r lib/sigar/libsigar-x86-*.so || die "Failed in removing X86 support libraries"
fi
# Currently unsupported platforms
# QA warning galore but testing/patches welcome
rm lib/sigar/libsigar-*freebsd*so \
lib/sigar/libsigar-*solaris*so \
lib/sigar/libsigar-*hpux*.sl \
lib/sigar/libsigar-*macosx*.dylib \
lib/sigar/libsigar-ia64-*.so \
lib/sigar/libsigar-ppc-*.so \
lib/sigar/libsigar-s390x*.so \
lib/sigar/*winnt* || die "Failed in removing unsupported platform libraries"

# gentoo specific paths
sed -i "s@\(node_id_file = \).*@\1${DATA_DIR}/node-id@g; \
s@\(message_journal_dir = \).*@\1${DATA_DIR}/data/journal@g; \
s@#\(content_packs_dir = \).*@\1/${DATA_DIR}/data/contentpacks@g" \
graylog.conf.example || die
}

src_compile() {
einfo "Nothing to compile; upstream supplies JAR only"
}

src_install() {
insinto /etc/graylog2
doins graylog.conf.example

insinto ${DATA_DIR}/data/contentpacks
doins data/contentpacks/grok-patterns.json

insinto "${INSTALL_DIR}"
doins *

doins -r lib plugin

newinitd "${FILESDIR}/initd-r1" graylog2
newconfd "${FILESDIR}/confd-r1" graylog2
}

0 comments on commit 0f56edc

Please sign in to comment.