Skip to content

Commit

Permalink
dev-lang/janet: bump version to 1.9.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Oz Tiram <[email protected]>
Closes: gentoo#16021
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
oz123 authored and juippis committed Jun 24, 2020
1 parent 0d4978a commit 0f6b2b8
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/janet/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST janet-1.8.1.tar.gz 977929 BLAKE2B 4cdf9e5dd7f4a1128438db8bec43c4f1919392bf6c317e2fca42b73826058cd98cec812c245354cc26f21edd4b9640f94dce1e82daa785b53e7e1e8fb45148a9 SHA512 e2296b16ad7df35e0f6ff0f56b9cd5071e887288df195ac0a14a73284a48f010cc26a413ea836aa3faa4385e25f7f313b183f0fbb8e6eebdc3975b69c62e4ebf
DIST janet-1.9.1.tar.gz 995046 BLAKE2B c65f59e874690b124b61811406670ed6bf9e23d930b5206a9fefebd64629a2287076a40db885b8a820d733a353237fea65dadccdf4efdd33f1537127f67e66b1 SHA512 4024b2f5bc52338b77c954e384157234ef3cecf21142ef60158adb656396b42accae3af8acb8e54f602f5fbce0e1e1f7f29030878ef2ac7055e933dd710db879
51 changes: 51 additions & 0 deletions dev-lang/janet/janet-1.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic

DESCRIPTION="A dynamic Lisp dialect and bytecode vm"
HOMEPAGE="https://janet-lang.org https://github.com/janet-lang/janet/"
SRC_URI="https://github.com/janet-lang/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"

src_configure() {
append-ldflags -Wl,-soname,libjanet.so.0
}

src_compile() {
# janet_build is the git hash of the commit related to the
# current release - it defines a constant which is then shown
# when starting janet
local janet_build='\"4ae372\"'
emake PREFIX="/usr" JANET_BUILD="${janet_build}"
emake PREFIX="/usr" build/janet.pc JANET_BUILD="${janet_build}"
emake PREFIX="/usr" docs JANET_BUILD="${janet_build}"
}

src_install() {
dobin "build/janet"
dobin "jpm"

doheader "src/include/janet.h"
doheader "src/conf/janetconf.h"

dolib.so "build/libjanet.so"
dosym libjanet.so /usr/$(get_libdir)/libjanet.so.1.9

if use static-libs; then
dolib.a "build/libjanet.a"
fi
doman "janet.1"
doman "jpm.1"

insinto /usr/$(get_libdir)/pkgconfig/
doins "build/janet.pc"
dodoc -r examples
dodoc "build/doc.html"
}

0 comments on commit 0f6b2b8

Please sign in to comment.