Skip to content

Commit

Permalink
games-simulation/openrct2: add 0.4,7, sync live
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/921108
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Jan 1, 2024
1 parent 8dbdeb0 commit 0f7180e
Show file tree
Hide file tree
Showing 3 changed files with 202 additions and 7 deletions.
4 changes: 4 additions & 0 deletions games-simulation/openrct2/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,8 @@
DIST openrct2-0.4.6.tar.gz 21003990 BLAKE2B 910e03586249c6e1fb1320cc47034c121f74da847305a041f18e5d593d1f494a608508b69f5a2b7919a4353eff4ea7d1dc5a5f8236c8857eca8175da04f9ec33 SHA512 fd48983f231b71cce9c7f59af88a46e81c7dfd005c77ce3594a43dfac87fd9d88dd900e3137c8c2c3bdeda974392c94412d031923e2191b44e974db1e3922712
DIST openrct2-0.4.7.tar.gz 21677290 BLAKE2B 934f26bd2117f4c5be1a20e5eff10a07a260a5f01d1df2f95f2a4b66adf603868e5ea33a88398857f35851575c38f28e6c98b7912ebe0cc3c97b745cbb280b02 SHA512 704007298d35b90cba592719649d066a2e8e546044f39ca0edddebd4c9e8e864ef8d1314e3bc5eaadf38fb2df54d9cb33ee9cb1cba3defd099aa34ea2a985a90
DIST openrct2-objects-1.3.11.zip 4705861 BLAKE2B 10a0477fd8db9374b0e667a34ec3b0cedf6cb29fc9b602da845e33272e072c55cf5fd30b9340ec4b763a9f324c72d126290651c9eddef07013857a8228978566 SHA512 98ab374a4899f60f45d6c87a570298a5788ec8cf277b67cb6b54c2f68388a99f201705377406b883eac45a97edff3cf7736898ed0b97a290f3d999dad7c821b9
DIST openrct2-objects-1.3.13.zip 4708920 BLAKE2B 16540805a0a9413de96837d23787ed47a84e570b2fa2480c89f4f9a644033c39ffa9167838c164511308942401fd054f2091362491a395c207bb3b779e7a740c SHA512 9e285cf922adb5b4d7c79f06cc7445e05bc755968099dc83fc62b411875bfe1e39a087559dc1730b44e78133f4c642da316fd94e7f0877189c59517e8bc1038f
DIST openrct2-openmusic-1.5.zip 40548101 BLAKE2B 11cf46a54716097038e134ae11aeb23823097ca96189dabeb0e43d7050d5e776aa309c38de247da15b1eec7ed6be6299d5673a92df1323cc3a4a5bbc4f48d567 SHA512 55d4afb854eaa5a69c42e7f0b26669c8fb58b2eba3e2892c655e76d8fab82e2734f39981d7f5ac69e11dc87d06c89795da2468feac3bc53ef6cfdd992e3924f3
DIST openrct2-opensound-1.0.3.zip 3820122 BLAKE2B 74265800595e36ac943bf2ee5d9c8f6cb3bbd5be3713d9590cb81faac4a75154dfbf9806b1b55e9c2426c84e3cf313a6271fc378ebfd4fa94821683157be5470 SHA512 89784703fb2cda67b5440e06381b44e59ce4a42a88004761c76f0c2b23f78be3692e5fe5e2c8655943e04f7a45e479cfcbc2c3998202222dab16a092b9a73195
DIST openrct2-replays-0.0.78.zip 1829988 BLAKE2B cf11a05f6ba5a2808cd4c016ac3c7537a0b49b67fd5ef5ab705aebd4ddc64dd4a82ea12d9c082fe66cebb57437c0d81052bcddfb94a0c9f7aab024a82c2e2ca8 SHA512 c6ff18c2206192ed4fb56535732137229f9bced96da00037d691bc64dcdb102cffe37f180054319e7c8ef8dbbd7de49792c3a7e845199fa180612ed97a149b32
DIST openrct2-title-sequences-0.4.6.zip 2547725 BLAKE2B 5f7b36cd1372106923000775307ea7ff8c142c3b1d026d84b86f255a629b0a2ac16a682300999789229a8833d4c7327c858c04710ecddfb97af1858ff121a5c4 SHA512 bd7d0f25047540572be75a4a8886e8dabdceb7a3e11fdeb5473b66fe804d829acdb763d34ec7cfa656df9bc527268a3e0e7ca09c699995804b22ff2a529ad5da
180 changes: 180 additions & 0 deletions games-simulation/openrct2/openrct2-0.4.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,180 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake readme.gentoo-r1 xdg-utils

MY_PN="OpenRCT2"
MY_PN_MSX="openmusic"
MY_PN_OBJ="objects"
MY_PN_RPL="replays"
MY_PN_SFX="opensound"
MY_PN_TS="title-sequences"
MY_PV_MSX="1.5"
MY_PV_OBJ="1.3.13"
MY_PV_RPL="0.0.78"
MY_PV_SFX="1.0.3"
MY_PV_TS="0.4.6"

DESCRIPTION="An open source re-implementation of Chris Sawyer's RollerCoaster Tycoon 2"
HOMEPAGE="https://openrct2.org/"
SRC_URI="
https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/${MY_PN}/${MY_PN_MSX}/releases/download/v${MY_PV_MSX}/${MY_PN_MSX}.zip -> ${PN}-${MY_PN_MSX}-${MY_PV_MSX}.zip
https://github.com/${MY_PN}/${MY_PN_OBJ}/releases/download/v${MY_PV_OBJ}/${MY_PN_OBJ}.zip -> ${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}.zip
https://github.com/${MY_PN}/OpenSoundEffects/releases/download/v${MY_PV_SFX}/${MY_PN_SFX}.zip -> ${PN}-${MY_PN_SFX}-${MY_PV_SFX}.zip
https://github.com/${MY_PN}/${MY_PN_TS}/releases/download/v${MY_PV_TS}/${MY_PN_TS}.zip -> ${PN}-${MY_PN_TS}-${MY_PV_TS}.zip
test? ( https://github.com/${MY_PN}/${MY_PN_RPL}/releases/download/v${MY_PV_RPL}/${MY_PN_RPL}.zip -> ${PN}-${MY_PN_RPL}-${MY_PV_RPL}.zip )
"
S="${WORKDIR}/${MY_PN}-${PV}"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="dedicated +flac +opengl scripting test +truetype +vorbis"
RESTRICT="!test? ( test )"

COMMON_DEPEND="
dev-libs/icu:=
dev-libs/jansson:=
dev-libs/libzip:=
media-libs/libpng:=
net-misc/curl[ssl]
sys-libs/zlib
!dedicated? (
media-libs/libsdl2
media-libs/speexdsp
flac? ( media-libs/flac:= )
opengl? ( virtual/opengl )
vorbis? ( media-libs/libvorbis )
)
dev-libs/openssl:0=
scripting? ( dev-lang/duktape:= )
truetype? (
media-libs/fontconfig:1.0
media-libs/freetype:2
)
"

RDEPEND="
${COMMON_DEPEND}
dedicated? (
acct-group/openrct2
acct-user/openrct2
)
"

DEPEND="
${COMMON_DEPEND}
dev-cpp/nlohmann_json
test? ( dev-cpp/gtest )
"

BDEPEND="
app-arch/unzip
virtual/pkgconfig
"

PATCHES=(
"${FILESDIR}/${PN}-0.4.0-include-additional-paths.patch"
"${FILESDIR}/${PN}-0.4.1-gtest-1.10.patch"
)

src_unpack() {
unpack "${P}".tar.gz

mkdir -p "${S}"/data || die
cd "${S}"/data
unpack "${PN}-${MY_PN_MSX}-${MY_PV_MSX}".zip
unpack "${PN}-${MY_PN_SFX}-${MY_PV_SFX}".zip

mkdir -p "${S}"/data/object || die
cd "${S}"/data/object || die
unpack "${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}".zip

mkdir -p "${S}"/data/sequence || die
cd "${S}"/data/sequence || die
unpack "${PN}-${MY_PN_TS}-${MY_PV_TS}".zip

if use test; then
mkdir -p "${S}"/testdata/replays || die
cd "${S}"/testdata/replays || die
unpack "${PN}-${MY_PN_RPL}-${MY_PV_RPL}".zip
fi
}

src_prepare() {
cmake_src_prepare

# Don't treat warnings as errors.
sed -e 's/-Werror//' -i CMakeLists.txt || die
}

src_configure() {
# Note: There is currently no support for Disord-RPC and Google Benchmark,
# as both packages do not exist in Gentoo, so support for them has been disabled.
local mycmakeargs=(
-DDISABLE_DISCORD_RPC=ON
$(usex !dedicated "-DDISABLE_FLAC=$(usex !flac)" "")
-DDISABLE_GOOGLE_BENCHMARK=ON
-DDISABLE_GUI=$(usex dedicated)
-DDISABLE_HTTP=OFF
-DDISABLE_IPO=ON
-DDISABLE_NETWORK=OFF
$(usex !dedicated "-DDISABLE_OPENGL=$(usex !opengl)" "")
-DDISABLE_TTF=$(usex !truetype)
$(usex !dedicated "-DDISABLE_VORBIS=$(usex !vorbis)" "")
-DDOWNLOAD_OBJECTS=OFF
-DDOWNLOAD_OPENMSX=OFF
-DDOWNLOAD_OPENSFX=OFF
-DDOWNLOAD_REPLAYS=OFF
-DDOWNLOAD_TITLE_SEQUENCES=OFF
-DENABLE_SCRIPTING=$(usex scripting)
-DOPENRCT2_USE_CCACHE=OFF
-DPORTABLE=OFF
-DSTATIC=OFF
-DWITH_TESTS=$(usex test)
-DUSE_MMAP=ON
)

cmake_src_configure
}

src_test() {
# Since the tests need the OpenRCT2 data,
# we need to symlink them into the build directory,
# otherwise some tests will fail, as they don't find the OpenRCT2 data.
# It is currently not possible to override that path.
# See: https://github.com/OpenRCT2/OpenRCT2/issues/6473
ln -s "${S}"/data "${BUILD_DIR}" || die

cmake_src_test
}

src_install() {
use scripting && DOCS+=( "distribution/scripting.md" "distribution/openrct2.d.ts" )

cmake_src_install

if use dedicated; then
newinitd "${FILESDIR}"/openrct2.initd openrct2
newconfd "${FILESDIR}"/openrct2.confd openrct2
fi

readme.gentoo_create_doc
}

pkg_postinst() {
readme.gentoo_print_elog

xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

pkg_postrm() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}
25 changes: 18 additions & 7 deletions games-simulation/openrct2/openrct2-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2023 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -9,17 +9,23 @@ EGIT_REPO_URI="https://github.com/OpenRCT2/OpenRCT2.git"
EGIT_BRANCH="develop"

MY_PN="OpenRCT2"
MY_PN_MSX="openmusic"
MY_PN_OBJ="objects"
MY_PN_RPL="replays"
MY_PN_SFX="opensound"
MY_PN_TS="title-sequences"
MY_PV_OBJ="1.3.11"
MY_PV_MSX="1.5"
MY_PV_OBJ="1.3.13"
MY_PV_RPL="0.0.78"
MY_PV_SFX="1.0.3"
MY_PV_TS="0.4.6"

DESCRIPTION="An open source re-implementation of Chris Sawyer's RollerCoaster Tycoon 2"
HOMEPAGE="https://openrct2.org/"
SRC_URI="
https://github.com/${MY_PN}/${MY_PN_MSX}/releases/download/v${MY_PV_MSX}/${MY_PN_MSX}.zip -> ${PN}-${MY_PN_MSX}-${MY_PV_MSX}.zip
https://github.com/${MY_PN}/${MY_PN_OBJ}/releases/download/v${MY_PV_OBJ}/${MY_PN_OBJ}.zip -> ${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}.zip
https://github.com/${MY_PN}/OpenSoundEffects/releases/download/v${MY_PV_SFX}/${MY_PN_SFX}.zip -> ${PN}-${MY_PN_SFX}-${MY_PV_SFX}.zip
https://github.com/${MY_PN}/${MY_PN_TS}/releases/download/v${MY_PV_TS}/${MY_PN_TS}.zip -> ${PN}-${MY_PN_TS}-${MY_PV_TS}.zip
test? ( https://github.com/${MY_PN}/${MY_PN_RPL}/releases/download/v${MY_PV_RPL}/${MY_PN_RPL}.zip -> ${PN}-${MY_PN_RPL}-${MY_PV_RPL}.zip )
"
Expand Down Expand Up @@ -78,16 +84,21 @@ PATCHES=(
)

src_unpack() {
git-r3_src_unpack
unpack "${P}".tar.gz

mkdir -p "${S}"/data/sequence || die
cd "${S}"/data/sequence || die
unpack "${PN}-${MY_PN_TS}-${MY_PV_TS}".zip
mkdir -p "${S}"/data || die
cd "${S}"/data
unpack "${PN}-${MY_PN_MSX}-${MY_PV_MSX}".zip
unpack "${PN}-${MY_PN_SFX}-${MY_PV_SFX}".zip

mkdir -p "${S}"/data/object || die
cd "${S}"/data/object || die
unpack "${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}".zip

mkdir -p "${S}"/data/sequence || die
cd "${S}"/data/sequence || die
unpack "${PN}-${MY_PN_TS}-${MY_PV_TS}".zip

if use test; then
mkdir -p "${S}"/testdata/replays || die
cd "${S}"/testdata/replays || die
Expand Down Expand Up @@ -167,5 +178,5 @@ pkg_postinst() {
pkg_postrm() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
xdg_mimeinf
}

0 comments on commit 0f7180e

Please sign in to comment.