Skip to content

Commit

Permalink
media-libs/gstreamer: bump to 1.12.3 for upstream bug fixes
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
leio committed Sep 18, 2017
1 parent 7725089 commit 0f72e9d
Show file tree
Hide file tree
Showing 2 changed files with 109 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/gstreamer/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST gstreamer-0.10.36.tar.xz 3025876 SHA256 9151aa108c177054387885763fa0e433e76
DIST gstreamer-1.10.3.tar.xz 3797056 SHA256 85b9dc1b2991f224fa90d534ec57014896c479e061dc9fa1bc16ae17cbebb63d SHA512 f601020026e159a8f52ade2fac2b25fb804a88bc6c04dc86ae9df64dc06b5b2315bb2209f8d3c17ca9f63379c9ab631d706c6138e4ed88db254442c05936774c WHIRLPOOL 30d9dde211767d35699c8f272b51389cf9a7856fbd2445dfe6d84cfd16f0c24653fc4615c510a61440ed59bb9ceedb33a9a89b691464673599fa203cc01203a9
DIST gstreamer-1.10.5.tar.xz 3798304 SHA256 bc06243600817f637029da29d089d5908d1d266542f68bf6626a10c5f05f1f1d SHA512 c138d672966232a4eb0fb4c49dbb39a7942d06b6474c9ee2c884eed2d470674dcbc4a3e2c7338472ac25b710788078241217391e7e5bc076ef21216cbaf0bc31 WHIRLPOOL bf915f18fd157b54f261891b1da434a99827d41236d2c699dce30efdbb4cd6139921c02866a0dff88da4db25fb3e09faca9eda494f74c354dec041a44262db45
DIST gstreamer-1.12.2.tar.xz 3172260 SHA256 9fde3f39a2ea984f9e07ce09250285ce91f6e3619d186889f75b5154ecf994ba SHA512 5d992a3727dc53478fd895d3c88ebdafcb6d5d0191a5ec8098ac5fe821e4f3c83451b4b1b089f08db0ed2475a97d3f1fcd1282581bcd106cf655914463891a5e WHIRLPOOL f9f68d331fce2360c8fa5f95d027c6928254b169dcae417c6251cb9736f424587b92bb8fd52d208fcefa6ea5ba081bc2957bebbe44d8d94b64040a1bd1b99d12
DIST gstreamer-1.12.3.tar.xz 3175480 SHA256 d388f492440897f02b01eebb033ca2d41078a3d85c0eddc030cdea5a337a216e SHA512 fceeeca4314aead7ff358db3474bd6fe1eef70f745a6ba20505da6c0caaea6ea6317246dc66c23edab396ca811a610c52fa930f8f99c701241ae7f15857aa2b0 WHIRLPOOL e9004b36af5964a3c0e947ea46fa643967a385d8bb0e92b60fc7882c3129b8ee576b93296fea607e115aaf196d0a10871862088688a6f6a3621ee0e69692ab8b
108 changes: 108 additions & 0 deletions media-libs/gstreamer/gstreamer-1.12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit bash-completion-r1 eutils multilib-minimal pax-utils

DESCRIPTION="Open source multimedia framework"
HOMEPAGE="https://gstreamer.freedesktop.org/"
SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"

LICENSE="LGPL-2+"
SLOT="1.0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="+caps +introspection nls +orc test unwind"

RDEPEND="
>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
unwind? (
>=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
dev-libs/elfutils[${MULTILIB_USEDEP}]
)
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.12
sys-devel/bison
sys-devel/flex
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
nls? ( sys-devel/gettext )
"
# gtk-doc-am to install API docs

src_configure() {
if [[ ${CHOST} == *-interix* ]] ; then
export ac_cv_lib_dl_dladdr=no
export ac_cv_func_poll=no
fi
if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
# GCC groks this, but then refers to an implementation (___multi3,
# ___udivti3) that don't exist (at least I can't find it), so force
# this one to be off, such that we use 2x64bit emulation code.
export gst_cv_uint128_t=no
fi

multilib-minimal_src_configure
}

multilib_src_configure() {
local completiondir=$(get_bashcompdir)
# Set 'libexecdir' to ABI-specific location for the library spawns
# helpers from there.
# Disable static archives and examples to speed up build time
# Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
local myconf=(
--libexecdir="${EPREFIX}"/usr/$(get_libdir)
--disable-debug
--disable-examples
--disable-static
--disable-valgrind
--enable-check
$(use_with unwind)
$(use_with unwind dw)
$(multilib_native_use_enable introspection)
$(use_enable nls)
$(use_enable test tests)
--with-bash-completion-dir="${completiondir%/*}"
--with-package-name="GStreamer ebuild for Gentoo"
--with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer"
)

if use caps ; then
myconf+=( --with-ptp-helper-permissions=capabilities )
else
myconf+=(
--with-ptp-helper-permissions=setuid-root
--with-ptp-helper-setuid-user=nobody
--with-ptp-helper-setuid-group=nobody
)
fi

ECONF_SOURCE="${S}" econf "${myconf[@]}"

if multilib_is_native_abi; then
local x
for x in gst libs plugins; do
ln -s "${S}"/docs/${x}/html docs/${x}/html || die
done
fi
}

multilib_src_install() {
# can't do "default", we want to install docs in multilib_src_install_all
emake DESTDIR="${D}" install

# Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
}

multilib_src_install_all() {
DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
einstalldocs
prune_libtool_files --modules

# Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
}

0 comments on commit 0f72e9d

Please sign in to comment.